LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   OpenLDAP server daemon cannot be start (https://www.linuxquestions.org/questions/linux-server-73/openldap-server-daemon-cannot-be-start-646326/)

prashanlk 06-02-2008 01:34 AM

OpenLDAP server daemon cannot be start
 
Hi all,

I tested an Open LDAP setup on my linux PC.i'm using Suse enterprise linux version 10.when i try to start the open LDAP daemon it gives me the following output;

Starting ldap-server/usr/lib/openldap/slapd: symbol lookup error: /usr/lib/openldap/slapd: undefined symbol: ldap_pvt_sasl_mutex_unlock
startproc: exit status of parent of /usr/lib/openldap/slapd: 127
failed

I was able to install the same LDAP setup on Open suse 10.2 Linux & it is working fine.Can any one help me on this?

Thanks

bathory 06-02-2008 03:17 AM

It seems that you miss the openldap-devel package, that provides the needed libraries and header files for slapd.

prashanlk 06-02-2008 05:09 AM

Open LDAP problem
 
Quote:

Originally Posted by bathory (Post 3171751)
It seems that you miss the openldap-devel package, that provides the needed libraries and header files for slapd.


Hi,

The openldap-devel Package already installed in the system.do you have any other idea related to this error....

Thanks

bathory 06-02-2008 07:50 AM

Since you have the openldap-devel package installed, then perhaps you need also the cyrus-sasl-devel package, judging from the name of the unresolved symbol.
You can use yast that can resolve those dependencies for you.

Regards

prashanlk 06-02-2008 08:33 AM

Hi,

cyrus-sasl-devel package also installed.still i don't have any idea why can't i start the ldap daemon.in open suse 10.2 linux i was able to setup an open ldap server sucessfully.any how thanx for helping me pal.if you can find any answer just let me know.

Thanks

alokguptag 07-04-2008 02:29 AM

service LDAP not starting
 
I tried to start ldap service after insatalling all packages requied for ldap.
following are the output of service start and /var/log/messages: -

[root@netsurfer openldap]# service ldap start
Checking configuration files for : config file testing succeeded
Starting slapd: [FAILED]
[root@netsurfer openldap]# more /var/log/messages
Jul 4 12:59:32 netsurfer slaptest: sql_select option missing
Jul 4 12:59:32 netsurfer slaptest: auxpropfunc error no mechanism available
Jul 4 12:59:32 netsurfer ldap: succeeded
Jul 4 12:59:32 netsurfer slapd[4115]: sql_select option missing
Jul 4 12:59:32 netsurfer slapd[4115]: auxpropfunc error no mechanism available
Jul 4 12:59:32 netsurfer ldap: slapd startup failed

kindly help in this matter.

alok

bathory 07-04-2008 02:48 AM

You should read this. It's for Redhat but it applies to any distro.

You should open a new thread since your problem is different from that of the OP.

Regards


All times are GMT -5. The time now is 09:06 PM.