LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 03-07-2007, 07:53 AM   #1
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current, SlackwareARM-current
Posts: 781

Rep: Reputation: 68
Only short filenames using ncpfs


Hi list,

I mount my personal directory on our institute's netware server using ncpfs. But the filenames are shortened to 8 characters, and I am not able to write files with long file names.

What do I need to do to enable long filenames? I Googled but couldn't find anything. Our sysadmin has no problems when he mounts the volumes on his Suse pc. He sent me his mount script, so it can't be related to mount options.

Slackware-current, kernel 2.6.20, uhm what else?

Cheers, Leon.
 
Old 03-07-2007, 04:27 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 334Reputation: 334Reputation: 334Reputation: 334
Your sysadmin should be able to help you figure this out.

Here are some links to documentation.

http://www.tldp.org/HOWTO/IPX-HOWTO.html

http://www.tldp.org/HOWTO/IPX-HOWTO-9.html#ss9.4
 
Old 03-08-2007, 03:37 AM   #3
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current, SlackwareARM-current
Posts: 781

Original Poster
Rep: Reputation: 68
Quote:
Originally Posted by stress_junkie
Your sysadmin should be able to help you figure this out.

Here are some links to documentation.

http://www.tldp.org/HOWTO/IPX-HOWTO.html

http://www.tldp.org/HOWTO/IPX-HOWTO-9.html#ss9.4
Thanks for the links.

However, the howto doesn't mention anything related to length of filenames. Just to be clear, I can see and mount volumes on the netware file server. It's just that they appear with abbreviated 8.3 filenames. Which is very annoying ;-)

Cheers, Leon.
 
Old 03-12-2007, 12:43 PM   #4
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current, SlackwareARM-current
Posts: 781

Original Poster
Rep: Reputation: 68
SOLVED

It turned out to be a kernel config option:
NCPFS_OS2_NS needs to be enabled for long file names.

Cheers, Leon.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ncpfs and files >2Gb Igor_Markov Linux - Networking 0 11-17-2006 09:27 AM
ncpfs selinux policy rhoekstra Linux - Security 2 10-17-2006 03:58 AM
ncpfs with RHEL3 sbrewer Linux - Networking 0 12-01-2004 05:41 AM
ncpfs mount labbob Mandriva 1 01-20-2004 04:06 PM
ncpfs and nautilus quazart Linux - Networking 3 12-16-2002 08:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 06:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration