-   Linux - Server (
-   -   OEL 5.5 and Oracle low decrease of memory (

soulman_yu 05-13-2011 12:59 PM

OEL 5.5 and Oracle low decrease of memory

I have an issue with few servers.

All have OEL 5.5 and various versions of oracle (mainly 10g something).

I've noticed on one machine that amount of free memory is slowly decreasing. When it comes to less then 30M, application has problems.

Ive tried adding mem on this machine (virtual), and it behaves the same.

The same is on physical machines I have simmilar, if not the same config. Variations are with physical memory installed, and it does not matter if servers have 2G, or 8G, free -m gives around 30 free

It does not swap, and does not make some big issues on other machines, but on this one, application that uses this DB timeouts the user.

Is there some chance to check what is creating this issue?

P.S. I've tried with DB admin to check something related to oracle itself, bit when we shutdown instance, Oracle frees 1.5G allocated to him, but nothing else.

Will try testimg a bit more, but any thought on this is usefull.
This is production server, so no big issues can be done. Will try to copy it to other hardware and do some testing, but then no App server available to attack it.

Any thoughts?

kbp 05-15-2011 03:11 AM

What have you set SGA to ?

soulman_yu 05-16-2011 05:55 AM


SQL> show sga

Total System Global Area 1107296256 bytes
Fixed Size 2095672 bytes
Variable Size 704644552 bytes
Database Buffers 385875968 bytes
Redo Buffers 14680064 bytes

SQL> show parameter sga

------------------------------------ ----------- ------------------------------
lock_sga boolean FALSE
pre_page_sga boolean FALSE
sga_max_size big integer 1056M
sga_target big integer 1056M

SQL> show parameter pga

------------------------------------ ----------- ------------------------------
pga_aggregate_target big integer 349M

kbp 05-16-2011 07:30 PM

So if you're giving the db 1GB how much is left for the OS ?

soulman_yu 06-09-2011 06:14 AM

Few issues were found that did the trick in some way.

First, Oracle version was 10g, but initial default configuration files (limits.conf or something) is preconfigured for Oracle 11g. That needed to be changed in this case.

Other main thing, and I cant believe I was so blind, was that command free -m gives you free memory, but OEL grabs the rest for I/O cache, so what should be looked at was buffer line in the output of this command (free -m)

So, no memory leak existed, and all we should have done is to change preconfiured Oracle files.


All times are GMT -5. The time now is 09:25 PM.