-   Linux - Server (
-   -   Odd Postfix Relay Issue (

chrisgti 06-08-2012 06:38 AM

Odd Postfix Relay Issue
Hi There,

I have 2 servers running Nagios with the Check_MK plugin. Both servers on the same site, on same subnet etc. One running Ubuntu, one running CentOS 6.2

I have an odd issue with the CentOS box when trying to send mail notifications from the Check_MK plugin.

Both servers relay via an Exchange 2010 server. A connector has been set up and mail relay is allowed.

If i send a test notification from nagios itself via a test notification from a native check, it works fine. I can telnet to the Exchange server on port 25 and manually send a message from the nagios address to my email address, and this arrives. However, when trying to send a notification via a check_mk check, it fails. However, all mail is sent from the ubuntu box.

I have tried copying the and transport config files from the working server to the non-working server but no matter what I try I always get "550 5.7.1 Unable to relay (in reply to RCPT TO command)"

I am struggling to see how it could be an exchange issue since the other server works fine and they both use the same connector.

I've tried changing a few of the postfix config settigs but not having much luck. Usually this just works.

Can anybody offer any insight as to why I can send mail from nagios and manually via telnet but a separate application doesn't work on the same box? When i tail /var/log/maillog i dont see any particular difference in the logs when sending via the different mean. What's odd is it all sits on top of nagios and uses the nagiosadmin account...

Even more oddly, there have been a few times when it was worked, for reasons that I have absolutely no idea!

Many Thanks

Ser Olmy 06-09-2012 04:57 PM

Have you tried capturing the SMTP traffic with tcpdump/Wireshark?

All times are GMT -5. The time now is 07:14 PM.