LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 08-06-2015, 09:02 AM   #1
PIKNIK
LQ Newbie
 
Registered: Aug 2015
Posts: 4

Rep: Reputation: Disabled
NTP-server with incorrent time and with stratum 1-3


Hello!

I need help with configure NTP-server on Ubuntu-server 14.04. But this ntp-server should issue not real UTC and UTC less on 1 hour. Wherein this server it should be with low stratum (1-3), otherwise clients refuses sync for this server.

The time on this server is set manually.

I tried configure so:

Code:
server 127.127.0.1
fudge 127.127.0.1 stratum 1
... and so:

Code:
server 127.127.0.1 iburst
fudge 127.127.0.1 stratum 1
... but clients see, what this server have too many big stratum (16) and do not sync.

I tried to wait, but nothing changed.


Please, see:
Have you ever seen this?
How to up NTP-server with manually time?

Thanks for help.
 
Old 08-06-2015, 09:35 AM   #2
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 7,831
Blog Entries: 15

Rep: Reputation: 1669Reputation: 1669Reputation: 1669Reputation: 1669Reputation: 1669Reputation: 1669Reputation: 1669Reputation: 1669Reputation: 1669Reputation: 1669Reputation: 1669
Why not use UTC for NTP and just have the servers use local timezone files to DISPLAY the time for the zone format you want?
 
Old 08-06-2015, 10:01 AM   #3
PIKNIK
LQ Newbie
 
Registered: Aug 2015
Posts: 4

Original Poster
Rep: Reputation: Disabled
Hello, MensaWater.

Cliens this NTP-server have the following features:

1. This is not linux-system;
2. Him not have admin-access (password overdue);
3. Without admin-password must not enter localtime manually, but can start/stop ntp-client and change ntp-servers list;
4. All this clients worked only if localtime is UTC -1 hour from realtime;
5. All this clients geographically remote.

Generally change time without physical access is only possible by this method.

Last edited by PIKNIK; 08-06-2015 at 11:00 AM.
 
Old 08-07-2015, 10:35 AM   #4
PIKNIK
LQ Newbie
 
Registered: Aug 2015
Posts: 4

Original Poster
Rep: Reputation: Disabled
Anyone?
 
Old 08-07-2015, 12:11 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 23,918

Rep: Reputation: 5268Reputation: 5268Reputation: 5268Reputation: 5268Reputation: 5268Reputation: 5268Reputation: 5268Reputation: 5268Reputation: 5268Reputation: 5268Reputation: 5268
Not enough information to say. What type of system is the client?

ntp is smart enough that you can not arbitrarily change time on server by a significant amount without the client detecting it as bad. In addition the client can detect if the server is not stable enough and also detect it as bad.

Restarting the server then the client may or may not work depending on how the client is configured. According to your second post this is not an option but you may be forced to stop ntp on the client, change time manually and then restart the client's ntp.
 
Old 08-14-2015, 04:00 AM   #6
PIKNIK
LQ Newbie
 
Registered: Aug 2015
Posts: 4

Original Poster
Rep: Reputation: Disabled
I configured NTP-server, how I planned.

The whole week configured and tested stratim command "ntpdate -q 127.0.0.1". Help me full clearing config file the NTP-server and enter this settings:

Code:
# Use the local clock
server 127.127.1.0 prefer
fudge  127.127.1.0 stratum 10


driftfile /var/lib/ntp/drift
broadcastdelay 0.008

# Give localhost full access rights
restrict 127.0.0.1

# Give machines on our network access to query us
restrict 0.0.0.0 mask 0.0.0.0 nomodify notrap
Do not stratum 3, but for NTP-clients this enough. Now my stratum on NTP-server 11 and this is good.

Thanks for help!

P.S.
Above all on this NTP-server I settinged hardclock by command # hwclock --systohc --utc . I have no idea helped this me or not, but I documenting this ther. Just in case.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ntp client is not syncing with ntp server time sagar666 Linux - Server 3 12-19-2014 05:47 AM
Allow NTP client to synchronise any stratum lvnt Linux - Software 3 04-20-2014 10:52 AM
ntp server keeps on changing time-local ntp server Gil@LQ Linux - Newbie 3 01-23-2013 10:33 AM
The peer's stratum is less than the host's stratum. (NTP) procfs Linux - General 2 04-17-2006 10:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 10:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration