LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 09-10-2009, 04:40 AM   #16
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Original Poster
Rep: Reputation: 107Reputation: 107

Quote:
Originally Posted by abhijeetdutta View Post
A server operating at stratum 1 belongs to the class of best NTP servers available, because it has a reference clock attached to it. As accurate reference clocks are expensive, only rather few of these servers are publically available.

A stratum 1 server should not only have a precise and well-maintained and calibrated reference clock, but also should be highly available as other systems may rely on its time service. Maybe that's the reason why not every NTP server with a reference clock is publically available.
Thanks abhijeet,
But why it is showing differently (stratum 1 and stratum 2) ? (Pls see my previous post, where I have shown all data)

Last edited by vikas027; 09-10-2009 at 04:41 AM. Reason: Added one line for more visiblity
 
1 members found this post helpful.
Old 09-10-2009, 06:57 AM   #17
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,541

Rep: Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060
Glad to know you got it going -- one last thing, though...

See if you can find the actual start-up, shut-down script in the initialization directories in /etc. It may be located in /etc/rc.d, /etc/rcn.d, /etc/init.d or some such (it's the file that is executed at boot and shutdown). If you ever need to fiddle with /etc/ntp.conf again, execute that file (as root) with a "stop" or "restart" argument (that will kill the currently running NTP daemon. You may want to edit the logging into that file (/tmp/ntp.log won't get that large and if there's a problem it's a convenient place to look for what's what). Makes life a little easier.

Glad you got it going.
 
Old 09-10-2009, 07:25 AM   #18
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Original Poster
Rep: Reputation: 107Reputation: 107
Quote:
Originally Posted by tronayne View Post
Glad to know you got it going -- one last thing, though...

See if you can find the actual start-up, shut-down script in the initialization directories in /etc. It may be located in /etc/rc.d, /etc/rcn.d, /etc/init.d or some such (it's the file that is executed at boot and shutdown). If you ever need to fiddle with /etc/ntp.conf again, execute that file (as root) with a "stop" or "restart" argument (that will kill the currently running NTP daemon. You may want to edit the logging into that file (/tmp/ntp.log won't get that large and if there's a problem it's a convenient place to look for what's what). Makes life a little easier.

Glad you got it going.
Yes, I am aware about it. I twill manage start/stop with logging.

But why it is showing differently (stratum 1 and stratum 2) ? (Pls see my previous post, where I have shown all data)
I am asking this just for sake of knowledge.
 
Old 09-11-2009, 07:04 AM   #19
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,541

Rep: Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060
There's a pretty concise explanation of stratum 0, stratum 1 and stratum 2 servers at http://www.endruntechnologies.com/stratum1.htm. There's also a pretty good article at http://en.wikipedia.org/wiki/Network_Time_Protocol; everything worth knowing about NTP.

It looks like the server you're using as a time source is a stratum 1 server (your system, by default, is stratum 2).
 
Old 02-18-2011, 11:14 PM   #20
newych
LQ Newbie
 
Registered: Feb 2011
Posts: 3

Rep: Reputation: 0
Unhappy I have a similar issue

I have same ntp issue on Xenserver
18 Feb 22:05:10 ntpd[16431]: logging to file /tmp/ntp.log
18 Feb 22:05:10 ntpd[16431]: precision = 1.000 usec
18 Feb 22:05:10 ntpd[16431]: ntp_io: estimated max descriptors: 1024, initial so
cket boundary: 16
18 Feb 22:05:10 ntpd[16431]: Listening on interface wildcard, 0.0.0.0#123 Disabl
ed
18 Feb 22:05:10 ntpd[16431]: Listening on interface lo, 127.0.0.1#123 Enabled
18 Feb 22:05:10 ntpd[16431]: Listening on interface xenbr0, 192.168.10.7#123 Ena
bled
18 Feb 22:05:10 ntpd[16431]: Listening on interface xenbr3, 192.168.10.7#123 Ena
bled
18 Feb 22:05:10 ntpd[16431]: kernel time sync status 0040
18 Feb 22:05:10 ntpd[16431]: getaddrinfo: "::1" invalid host address, ignored
18 Feb 22:05:10 ntpd[16431]: frequency initialized 0.000 PPM from /var/lib/ntp/d
rift

This is Xenserver's ntp.conf file looks like
# Permit time synchronization with our time source, but do not
# permit the source to query or modify the service on this system.
restrict default kod nomodify notrap nopeer noquery
restrict -6 default kod nomodify notrap nopeer noquery

# Permit all access over the loopback interface. This could
# be tightened as well, but to do so would effect some of
# the administrative functions.
restrict 127.0.0.1
restrict -6 ::1

# Hosts on local network are less restricted.
#restrict 192.168.1.0 mask 255.255.255.0 nomodify notrap

# Use Xen's public servers.

#broadcast 192.168.1.255 key 42# broadcast server
#broadcastclient# broadcast client
#broadcast 224.0.1.1 key 42# multicast server
#multicastclient 224.0.1.1# multicast client
#manycastserver 239.255.254.254# manycast server
#manycastclient 239.255.254.254 key 42# manycast client
# Undisciplined Local Clock. This is a fake driver intended for backup
# and when no outside source of synchronized time is available.
server127.127.1.0# local clock
fudge127.127.1.0 stratum 10

# Drift file. Put this in a directory which the daemon can write to.
# No symbolic links allowed, either, since the daemon updates the file
# by creating a temporary in the same directory and then rename()'ing
# it to the file.
driftfile /var/lib/ntp/drift

# Key file containing the keys and key identifiers used when operating
# with symmetric key cryptography.
keys /etc/ntp/keys

# Specify the key identifiers which are trusted.
#trustedkey 4 8 42

# Specify the key identifier to use with the ntpdc utility.
#requestkey 8

# Specify the key identifier to use with the ntpq utility.
#controlkey 8

# Specify the key identifier to use with the ntpq utility.
#controlkey 8
server 64.90.182.55
server 0.pool.ntp.org
server 1.pool.ntp.org
server 2.pool.ntp.org

I do not understand what is the "::1" mean in error log
Can anybody help me? Thank you very much.

Last edited by newych; 02-18-2011 at 11:21 PM.
 
Old 02-21-2011, 01:09 AM   #21
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Original Poster
Rep: Reputation: 107Reputation: 107
Hi newych,

I do not know much about your error. But could you please try the below configuration.
Remove your old file and just use these 4 lines in your ntp.conf

Code:
server 64.90.182.55 prefer
restrict 127.0.0.1       
driftfile /etc/ntp/drift
broadcastdelay  0.008
Then run the below commands
Code:
echo "0.0" > /etc/ntp/drift
service ntpd stop
>/tmp/ntp.log                
/usr/sbin/ntpd -g -p /var/run/ntpd.pid -l /tmp/ntp.log

Verify, after waiting for around 5 mins by
ntpq -pn and post your output here.

Last edited by vikas027; 02-21-2011 at 01:11 AM.
 
Old 02-22-2011, 01:07 PM   #22
newych
LQ Newbie
 
Registered: Feb 2011
Posts: 3

Rep: Reputation: 0
Hi vikas027,
After run ntpq -pn 64.90.182.55, i got following result:
ntpq -pn 64.90.182.55
remote refid st t when poll reach delay offset jitter
==============================================================================
*127.127.1.0 .ACTS. 0 l 17 64 377 0.000 0.000 0.000
Below is my /tmp/ntp.log
Shutting down ntpd: [ OK ]
22 Feb 11:52:48 ntpd[25034]: logging to file /tmp/ntp.log
22 Feb 11:52:48 ntpd[25034]: precision = 1.000 usec
22 Feb 11:52:48 ntpd[25034]: ntp_io: estimated max descriptors: 1024, initial so
cket boundary: 16
22 Feb 11:52:48 ntpd[25034]: Listening on interface wildcard, 0.0.0.0#123 Disabl
ed
22 Feb 11:52:48 ntpd[25034]: Listening on interface lo, 127.0.0.1#123 Enabled
22 Feb 11:52:48 ntpd[25034]: Listening on interface xapi2, 192.168.10.7#123 Enab
led
22 Feb 11:52:48 ntpd[25034]: kernel time sync status 0040
" unknown, line ignored034]: configure: keyword "prefer
I also have this issue posted on Citrix forums at: http://forums.citrix.com/thread.jspa?threadID=258940
From page 2 to the end. It will tell you what i did in the last few days,
 
Old 02-23-2011, 03:10 PM   #23
newych
LQ Newbie
 
Registered: Feb 2011
Posts: 3

Rep: Reputation: 0
My issue is resolved. It was caused by enable "Auto Dos" on my HP Procurve 1810G. When i disable "Auto Dos", ntpd service start without any issue. Thanks for your help.
 
Old 05-10-2012, 01:19 AM   #24
arvind lavania
LQ Newbie
 
Registered: May 2012
Posts: 3
Blog Entries: 3

Rep: Reputation: Disabled
Unhappy ntp service not syncing properly

once again i have same issue..i have try almost everything mention here in this post please help me now how can i solve this issue with your help..


thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ntp drift file in /etc/ntp instead of /var/lib/ntp - suggestion for a patch in Slack niels.horn Slackware 16 05-07-2009 07:35 PM
synchronize ntp client rizvi_iut Linux - Newbie 6 12-08-2008 09:54 PM
Setting Up NTP Client/Server kaplan71 SUSE / openSUSE 2 05-31-2006 04:38 PM
NTP Client How to Sync automatically minil Programming 3 03-03-2005 02:52 AM
Need help with NTP server/client setup ncorreia Linux - General 0 11-06-2003 05:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 08:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration