-   Linux - Server (
-   -   Not Found The requested URL /nagios/cgi-bin/tac.cgi was not found on this server. (

amanamu 11-15-2012 05:30 AM

Not Found The requested URL /nagios/cgi-bin/tac.cgi was not found on this server.
I have installed Nagios (3.4.1 , /usr/local/nagios), Apache (2.0.64 , /usr/local/apache2) and PHP (5.4.8 , /usr/local/php) from source on my RHEL 6.0 Server.

i tested the simple PHP code <?php echo "Hello" ?> that gave me output Hello when opened at http://localhost/test.php It means php is working fine

But when i do http://localhost/nagios It opens the default page.when clicked on links given at default page It gives error like
The requested URL /nagios/cgi-bin/statusmap.cgi was not found on this server.
when clicked on "Map" link .
but there is no cgi-bin directory in /usr/local/nagios or in its internal directories. only there are certain .cgi files present in "/usr/local/nagios/sbin/"

I declared Alias /nagios /usr/local/nagios/share/
I Searched index.html and changed it to index.php in the /usr/local/apache2/conf/httpd.conf file

Tell me where is the fault.....

bathory 11-15-2012 09:53 AM


You need to define the cgi-bin directory too
See here


amanamu 11-23-2012 02:22 AM

It open the pages, but still with permission warning inside the page
1 Attachment(s)
Please check the screenshot, it displays the same error at every page beneath the Tactical Overview.....

bathory 11-23-2012 04:43 AM


This is some sort of authentication error. I guess you have the default

in cgi.cfg, but don't have a .htaccess to authenticate user(s)

jinguo 02-07-2013 12:05 AM

if i set "use_authentication=1" to "use_authentication=0", the error was gone. but it seems better to set as default, so then how can we do.
i try write a .htaccess file under /usr/local/nagios/sbin/, but it still has the same error

any idea?

bathory 02-07-2013 03:45 AM


Please don't hijack others' threads. Start your own thread giving details about your problem.
In the meantime you can have a look at nagios book


All times are GMT -5. The time now is 03:07 PM.