LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 02-17-2016, 04:46 PM   #1
ttiihone
LQ Newbie
 
Registered: Jan 2015
Posts: 4

Rep: Reputation: Disabled
Question Nodejs v5.6.0 ./configure command -> ERROR


Hello, gurus. Need some help here..;

I have a hosted Debian 6 32bit virtual server which I'm trying to put up and running for my Ruby On Rails-website but while configuring Node-v5.6.0 I get the following error message when executing the command "./configure". I have tried Googling around but I altogether so newbie with configuring Linux that I cannot seem to find any advices from anywhere. Can You help on what I should do now?

(I DID have an up and running Linux server last summer but my subscription to the virtual server service was terminated by the host because I couldn't pay the bills, but today those old instructions of mine don't seem to apply..)


admin@www:~/node-v5.6.0$ sudo apt-get install -y build-essential
[sudo] password for admin:
Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
admin@www:~/node-v5.6.0$ ./configure
WARNING: C++ compiler too old, need g++ 4.8 or clang++ 3.4 (CXX=g++)
 
Old 02-18-2016, 06:20 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,229

Rep: Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522
you are aware that debian 6 is now at it's End Of Life
there is no more support for 6
https://www.debian.org/News/2016/20160212

please stay up to date and install debian 8
 
1 members found this post helpful.
Old 02-19-2016, 05:34 AM   #3
ttiihone
LQ Newbie
 
Registered: Jan 2015
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by John VV View Post
you are aware that debian 6 is now at it's End Of Life
there is no more support for 6
https://www.debian.org/News/2016/20160212

please stay up to date and install debian 8

OK, thank You for the info!

Yes, Debian 8 actually IS available as a virtual server at hostinger.fi but that option does not have this ISPConfig3 option available for automatic installation. I don't remember even that what this ISPConfig3 is or do I even need it.. I'm having this virtual server for ONLY for my Ruby on Rails web site and nothing more. Can You help? It's weird that Debian 6 is still available as a preset installation option there in Hostinger but that's the only one with ISPConfig3. And I'm unable to reach my earlier tutor/friend with this matter so I'm pretty much stuck here..

Thank You!
 
  


Reply

Tags
./configure, node.js


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] nodejs installation error yashfire007 Linux - Newbie 4 05-15-2013 10:37 AM
[SOLVED] nodejs, nodejs-dev incompatibility in Ubintu? mjbradakis Linux - Software 1 03-25-2013 12:50 AM
installing Opera web browser, error when using the ./configure command aristocratic Linux - Software 16 07-31-2012 11:44 AM
I get error message when I try to use ,/configure command royeo Linux - Newbie 10 08-11-2006 07:16 AM
./Configure "Permision Denied" error when atempting to use ./configure command in RH8 canegames Linux - Software 9 06-29-2006 02:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 02:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration