-   Linux - Server (
-   -   No Internet traffic through the PPTP VPN connection (

tghasemi 02-21-2011 05:28 PM

No Internet traffic through the PPTP VPN connection
I went through this guide and did everything step by step. everything works fine, clients can connect to the vpn server with no problems and they can ping local machines! but no internet access through the vpn connection unless i uncheck the default gateway option on my client machine which is not what i want. I want my clients to get my server’s ip address. my server is behind a router (router’s ip : | server’s local ip: so i used localip & remoteip in pptpd.conf. it think there is something wrong with routing or firewall rules, because it seems that the DNS resolution works .. when i try to browse a website my browser says “Waiting for…” and it stays on that stage forever ! the funny part is that works fine (don’t know how). does anybody has any idea about the issue ?
p.s :
* I have already opened the port in on my router. I even tried it locally to make sure that the router is not the problem here.
* already added ms-dns / ms-dns to pptpd-options. (found another guide that suggested to do this, before adding these two lines even dns resolution was not working.)

tghasemi 02-23-2011 12:08 AM

added the following line into etc/ppp/ip-up

/sbin/ifconfig $1 mtu 1400

and that fixed the issue :)

narcberry 05-21-2012 10:40 AM

This fixed it for me as well.

In addition to mysteriously working while the rest of the internet was unavailable, using telnet to make an HTTP 1.0 request works fine as well. would be stuck in the browser waiting for a response, but telnet would get the entire front page contents. A subsequent request to using the browser would retrieve partial content. Huh?

DNS worked fine.
TCP connectivity appeared fine.

Thank you, thank you, thank you.

All times are GMT -5. The time now is 06:28 PM.