LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 01-21-2008, 12:56 PM   #1
Lionhard
LQ Newbie
 
Registered: May 2007
Location: Brasilia, BR
Distribution: Gentoo
Posts: 17

Rep: Reputation: 0
NIS server fails to bind to itself


Hi all.
I have a debian machine, which is going to be a NIS master server. I've followed many how-tos in the net (although many of them are rather old) and i've installed a NIS server with the apt-get command.
I think I've configured everything just fine, but the ypbind fails to bind. It's running in the server machine, and it keeps broadcasting for the server.

ypbind -d:
Code:
taita99:~# ypbind -d
6384: parsing config file
6384: Trying entry: ypserver taita99.jb.br
6384: parsed ypserver taita99.jb.br
6384: add_server() domain: jb.br, host: taita99.jb.br, slot: 0
6384: [Welcome to ypbind-mt, version 1.20.1]

6384: ping interval is 20 seconds

6386: NetworkManager is running.

6386: Are offline
6386: interface: org.freedesktop.DBus, object path: /org/freedesktop/DBus, method: NameAcquired
ypserv_test
Code:
taita99:~# ypserv_test
ypproc_match_2: ypserv sends -3 instead of YP_TRUE
ypproc_next_2: ypserv sends 2 instead of YP_TRUE
I must admit that i don't know what to do. I've done all the steps to install it... the ypinit stuff, the make stuff...

Thanks.
 
Old 01-22-2008, 11:52 AM   #2
Lionhard
LQ Newbie
 
Registered: May 2007
Location: Brasilia, BR
Distribution: Gentoo
Posts: 17

Original Poster
Rep: Reputation: 0
OK, I've figured out what was. The ypbind was looking for dbus/NetworkManager to tell if there's any network connection. I just ran ypbind with the -no-dbus option, and everything worked very well.
Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba server ok at boot, later fails to bind to IP. smbd restart doesn't help. tisource Linux - Networking 1 04-09-2005 08:16 AM
Slave can't bind with running NIS server rclancy Linux - Networking 0 02-23-2005 05:48 PM
how to join NIS server (SUN machine) to Linux NIS server? KoRiR Linux - Networking 3 04-28-2004 01:19 PM
How to setup a Solaris NIS client while with a Linux NIS server? ntcm Solaris / OpenSolaris 1 03-31-2004 06:10 AM
How to setup a Solaris NIS client while with a Linux NIS server? ntcm Linux - General 1 03-31-2004 06:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 10:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration