-   Linux - Server (
-   -   NFS stopped working (

John_Zbesko 09-14-2007 02:11 PM

NFS stopped working
I have a home server connected to several machines in my household. I previously had NFS shares on the server that were available to the other machines. Now when I attempt to mount a server share from a terminal on another machine, it simply "hangs" there until I hit CTRL-C or eventually times out. I am able to "see" the server's samba shares (same directories) and I am able to mount a machine NFS share on the server.

I've tried many things: reboot, re-install the nfs server, try either the kernel or user-space NFS server, diagnose w/ rpcinfo and showmount, etc.

Grasping at straws, the only thing I can think of is that I was also trying to use tos on the server firewall (using firestarter) to prioritize traffic to a wireless router that is also my Vonage voip adapter.

How do I troubleshoot this?! /var/log/messages or ./syslog show nothing relevant, either.

John_Zbesko 09-18-2007 09:30 AM

Problem solved. I had a firewall issue. Using firestarter, I had incorrectly set up an inbound traffic policy to eth2 (my local/lan ethernet card). When I changed "eth2" to "", it worked.

I hope I haven't just opened up my network to the world...

All times are GMT -5. The time now is 11:00 PM.