LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 10-19-2010, 06:46 AM   #1
ddaas
Member
 
Registered: Oct 2004
Location: Romania
Distribution: Ubuntu server, FreeBsd
Posts: 452

Rep: Reputation: 30
nfs read only issue


Hello,
I'am using nfs to mount different directories.
ODT Documents appears read only. When I open a document I get "odt document is locket for editing by UNKNOWN user".
The partition is rw, I can delete/modify all the other documents. The problem is only for ODT (open office).
I am using Ubuntu 10.10.
Other distribution could rw odt documents.
I think something is missing but I don't know what.

Any ideas?

Thanks
 
Old 10-19-2010, 07:01 AM   #2
frogweasel
LQ Newbie
 
Registered: Mar 2008
Location: Poquoson, VA
Distribution: Ubuntu 10.04
Posts: 12

Rep: Reputation: 0
Have you checked the file ownership and permissions?
Can you "Save As" another filename in that same directory?
 
Old 10-19-2010, 07:18 AM   #3
ddaas
Member
 
Registered: Oct 2004
Location: Romania
Distribution: Ubuntu server, FreeBsd
Posts: 452

Original Poster
Rep: Reputation: 30
Permissions are ok. I'am the owner. I've also tried 777.
I can save files in that directory.
I suspect something from OpenOffice somehow.

The problem appeared when I upgrade from ubuntu 10.04 to 10.10. All other computers with the same configuratin can write the files on the nfs server.
 
Old 11-05-2010, 05:45 AM   #4
ddaas
Member
 
Registered: Oct 2004
Location: Romania
Distribution: Ubuntu server, FreeBsd
Posts: 452

Original Poster
Rep: Reputation: 30
this is very strange. Over the Internet (port-forwarding) I can mount the share and have rw access to odt files, but from the LAN I can't (only ro access to odt fiels.
The files seems opened by another user. I can delete them if I want.
 
Old 03-26-2011, 03:27 PM   #5
eflester
Member
 
Registered: Sep 2003
Location: Washington
Distribution: RH9, SuSE 9.0, Slackware 10, Mandrake 10, Debian woody & sarge, FC2-3, OpenBSD
Posts: 71

Rep: Reputation: 17
Did you ever solve this?

I am experiencing the same problem. I found someone using Slackware who said the problem comes from Open Office and the way it deals with NFS file locking. That article suggesting commenting out some lines in /usr/lib/openoffice/program/soffice, but this did not work for me. I also only have the problem with OO files, when I try to open or save them from or to my NAS, using nfs to mount the NAS on the local machine.
 
Old 03-26-2011, 06:17 PM   #6
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,689

Rep: Reputation: 305Reputation: 305Reputation: 305Reputation: 305
@ ddas

Hi ddas,

As I can understand you have configured a NFS server and you have configured a couple of NFS shares.

You are saying that you are able to r/w and open all files perfectly fine except ODT files. When you try to open ODT files on Ubuntu 10.10 machine you get an error message that the file has been locked by an unknown user. However, you are able to open ODT files from other distributions but not able to do it on Ubuntu.

Please let me know if you have tried to do "lsof | grep openoffice" to see which files are locked by open office on the mahcine. If it is not showing up the file as locked that you are trying to open then copy that file to local workstation and see if you are able to open it up locally because then it shouldn't be locked by anyone.

If it still doesn't open then there is something wrong with Open Office application on Ubuntu. If it opens fine then let us know so that we can start troubleshooting fron file lock/network perspective.

Note: You can find more information on lsof on: http://linux.about.com/library/cmd/blcmdl8_lsof.htm

Last edited by T3RM1NVT0R; 03-26-2011 at 06:19 PM.
 
Old 03-26-2011, 10:33 PM   #7
eflester
Member
 
Registered: Sep 2003
Location: Washington
Distribution: RH9, SuSE 9.0, Slackware 10, Mandrake 10, Debian woody & sarge, FC2-3, OpenBSD
Posts: 71

Rep: Reputation: 17
solution

I did find a solution to this problem on another forum. In a nutshell, the problem resides with OpenOffice. To fix this problem in Ubuntu 10.10 with OpenOffice 3.2.1, I had to edit the file /usr/lib/openoffice/program/soffice. In this file there is a section that begins with the comment "#adjust environment". Comment out every line of the lengthy if statement all the way to its fi, which appears just above the line "if [ -z "$SAL_NOOPENGL" ]; then" Your result should look like this:

# adjust environment

#if [ -z "$SAL_ENABLE_FILE_LOCKING" ]; then
# case "$FILE_LOCKING" in
# auto)
# home_on_nfs "$@"
# if [ $? = 0 ]; then
# STAR_PROFILE_LOCKING_DISABLED=1
# export STAR_PROFILE_LOCKING_DISABLED
# fi
# file_on_nfs "$@"
# if [ $? = 0 ]; then
# SAL_ENABLE_FILE_LOCKING=1
# export SAL_ENABLE_FILE_LOCKING
# # for safety
# STAR_ENABLE_FILE_LOCKING=0
# export STAR_ENABLE_FILE_LOCKING
# else
# # file locking now enabled by default
# SAL_ENABLE_FILE_LOCKING=1
# export SAL_ENABLE_FILE_LOCKING
# fi
# ;;
# yes)
# SAL_ENABLE_FILE_LOCKING=1
# export SAL_ENABLE_FILE_LOCKING
# ;;
# no)
# SAL_ENABLE_FILE_LOCKING=0
# export SAL_ENABLE_FILE_LOCKING
#
# # for safety
# STAR_ENABLE_FILE_LOCKING=0
# export STAR_ENABLE_FILE_LOCKING
# STAR_PROFILE_LOCKING_DISABLED=1
# export STAR_PROFILE_LOCKING_DISABLED
# esac
#fi
 
1 members found this post helpful.
Old 03-29-2011, 01:54 PM   #8
ddaas
Member
 
Registered: Oct 2004
Location: Romania
Distribution: Ubuntu server, FreeBsd
Posts: 452

Original Poster
Rep: Reputation: 30
I think it's bug from OO. Based on the version of OpenOffice it works or not. And the server has the same configuration always.
I've solved the problem with an upgrade.
 
Old 03-29-2011, 02:10 PM   #9
eflester
Member
 
Registered: Sep 2003
Location: Washington
Distribution: RH9, SuSE 9.0, Slackware 10, Mandrake 10, Debian woody & sarge, FC2-3, OpenBSD
Posts: 71

Rep: Reputation: 17
OO owns this one

Yes, I agree, I believe the problem is with OO. I did not change anything in my local or server nfs config to fix this, only the config file from OO. A newer version of OO might indeed work better, I did not try that. I have also read that installing and using nfs v4 will fix this problem, but I did not try that either.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nfs mount can't read superblock nafan Linux - Networking 7 04-12-2010 06:39 AM
read only permission on NFS filesystem smallbook Linux - Server 2 06-06-2008 03:17 AM
NFS -- no read write ihopeto Linux - Networking 0 01-18-2006 10:31 PM
NFS killing me, (can't read superblock) wael_nasreddine Linux - Networking 13 06-09-2005 06:41 PM
10.2 nfs read only problem salparadise Mandriva 7 05-04-2005 06:05 AM


All times are GMT -5. The time now is 10:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration