LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 07-28-2009, 01:09 PM   #1
floweringmind
LQ Newbie
 
Registered: Jul 2009
Posts: 15

Rep: Reputation: 0
Need help with Postfix configuration as my mail is being caught by spam filters


I host a bunch of sites and when I email out from one of my virtual hosts the email is going into my spam folder on gmail. I noticed that the mailed-by is my primary domain and should be the virtual domain. I am not sure what I need to do to configure postfix to do that.

Do I need to change mydomainname.com (I put this in place of my real domain name)?

Here is my current postfix configuration:

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
#smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
#smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
#smtpd_use_tls=yes
#smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
#smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = mydomainname.com
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination permit_inet_interfaces
broken_sasl_auth_clients = yes

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = mydomainname.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = $myhostname, localhost
virtual_alias_maps = hash:/etc/postfix/virtual
relayhost =
mynetworks = 127.0.0.0/8
#mailbox_command = /usr/bin/procmail
#mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
smtpd_helo_required = yes
smtpd_delay_reject = no
disable_vrfy_command = yes
# Fixes the "do not list domain in BOTH" nags, also the future default behavior
# To enable subdomain matching, use .domain.com
parent_domain_matches_subdomains =
 
Old 07-28-2009, 05:39 PM   #2
archangel_617b
Member
 
Registered: Sep 2003
Location: GMT -08:00
Distribution: Ubuntu, RHEL/CentOS, Fedora
Posts: 234

Rep: Reputation: 42
I've never had this issue, maybe a MUA problem? Can you clarify how you're generating the email?

Thanks,
- Arch
 
Old 07-28-2009, 09:29 PM   #3
floweringmind
LQ Newbie
 
Registered: Jul 2009
Posts: 15

Original Poster
Rep: Reputation: 0
Email

Any email sent from any emailer will show delivered-by and the primary domain. Maybe gmail is doing this because it is doing a reverse dns lookup.

Chris
 
Old 07-28-2009, 10:04 PM   #4
floweringmind
LQ Newbie
 
Registered: Jul 2009
Posts: 15

Original Poster
Rep: Reputation: 0
Email test

I did a test to one of my virtual server email address and instead of the virtualserver domain coming up it was my domain name.

S 220 mydomainname.com ESMTP Postfix
 
Old 07-29-2009, 12:50 AM   #5
archangel_617b
Member
 
Registered: Sep 2003
Location: GMT -08:00
Distribution: Ubuntu, RHEL/CentOS, Fedora
Posts: 234

Rep: Reputation: 42
Quote:
Originally Posted by floweringmind View Post
I did a test to one of my virtual server email address and instead of the virtualserver domain coming up it was my domain name.

S 220 mydomainname.com ESMTP Postfix
Sounds like you're right, it is more like from reverse DNS lookup or from the EHLO. In which case, the best you can do is ensure you have your reverse DNS setup for the mail server and for the love of God, make sure your IP resolves to 1 name and that 1 name resolves to the same IP.

If this isn't an issue you can resolve, you will have to relay outgoing mail through the ISP and depending on the volume of mail, you may find you have to negotiate with them to ensure *they* don't blacklist you. But with the server providers I've dealt with, this has never been a problem.

- Arch
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Postfix Backup Mail Server Anti-Spam / Anti-Virus Configuration LXer Syndicated Linux News 0 05-05-2009 02:00 PM
Ubuntu server with postfix. My mail goes to Spam in Gmail and Yahoo Mail. Ideeas? bob808 Linux - Server 4 02-07-2009 04:11 PM
LXer: How To Fight Spam Using Your Postfix Configuration LXer Syndicated Linux News 0 09-07-2006 08:21 PM
I've had it with M$ Exchange and commercial spam filters - going Postfix KimVette General 4 10-22-2005 11:19 PM
sendmail getting e-mail through others spam filters grizzly Linux - Software 1 08-20-2005 05:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 10:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration