LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   Need help with Postfix configuration as my mail is being caught by spam filters (https://www.linuxquestions.org/questions/linux-server-73/need-help-with-postfix-configuration-as-my-mail-is-being-caught-by-spam-filters-743461/)

floweringmind 07-28-2009 02:09 PM

Need help with Postfix configuration as my mail is being caught by spam filters
 
I host a bunch of sites and when I email out from one of my virtual hosts the email is going into my spam folder on gmail. I noticed that the mailed-by is my primary domain and should be the virtual domain. I am not sure what I need to do to configure postfix to do that.

Do I need to change mydomainname.com (I put this in place of my real domain name)?

Here is my current postfix configuration:

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
#smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
#smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
#smtpd_use_tls=yes
#smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
#smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = mydomainname.com
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination permit_inet_interfaces
broken_sasl_auth_clients = yes

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = mydomainname.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = $myhostname, localhost
virtual_alias_maps = hash:/etc/postfix/virtual
relayhost =
mynetworks = 127.0.0.0/8
#mailbox_command = /usr/bin/procmail
#mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
smtpd_helo_required = yes
smtpd_delay_reject = no
disable_vrfy_command = yes
# Fixes the "do not list domain in BOTH" nags, also the future default behavior
# To enable subdomain matching, use .domain.com
parent_domain_matches_subdomains =

archangel_617b 07-28-2009 06:39 PM

I've never had this issue, maybe a MUA problem? Can you clarify how you're generating the email?

Thanks,
- Arch

floweringmind 07-28-2009 10:29 PM

Email
 
Any email sent from any emailer will show delivered-by and the primary domain. Maybe gmail is doing this because it is doing a reverse dns lookup.

Chris

floweringmind 07-28-2009 11:04 PM

Email test
 
I did a test to one of my virtual server email address and instead of the virtualserver domain coming up it was my domain name.

S 220 mydomainname.com ESMTP Postfix

archangel_617b 07-29-2009 01:50 AM

Quote:

Originally Posted by floweringmind (Post 3623708)
I did a test to one of my virtual server email address and instead of the virtualserver domain coming up it was my domain name.

S 220 mydomainname.com ESMTP Postfix

Sounds like you're right, it is more like from reverse DNS lookup or from the EHLO. In which case, the best you can do is ensure you have your reverse DNS setup for the mail server and for the love of God, make sure your IP resolves to 1 name and that 1 name resolves to the same IP.

If this isn't an issue you can resolve, you will have to relay outgoing mail through the ISP and depending on the volume of mail, you may find you have to negotiate with them to ensure *they* don't blacklist you. But with the server providers I've dealt with, this has never been a problem.

- Arch


All times are GMT -5. The time now is 07:16 AM.