-   Linux - Server (
-   -   Need help understanding Yum update dependency issues (

snowweb 08-29-2012 07:10 AM

Need help understanding Yum update dependency issues
When I run "yum update" I get the following error:


Error: Package: clamsmtp-1.10-6.el6.x86_64 (@epel)
          Requires: clamav-server
          Removing: clamd-0.97.5-1.el6.x86_64 (@epel)
              clamav-server = 0.97.5-1.el6
          Updated By: clamd-0.97.5-2.el6.rf.x86_64 (rpmforge)
              Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I really want to fix the problem rather than "work around" it, but don't know where to begin.

Perhaps some kind soul could point me in the right direction please?

Below are the details of the server. Please let me know what else I need to provide:

uname -a
Linux 2.6.32-279.2.1.el6.x86_64 #1 SMP Fri Jul 20 01:55:29 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

I'm using clamsmtp for scanning mail in conjunction with Postfix.

Thanks in advance :-)

acid_kewpie 08-29-2012 07:24 AM

ok, so it looks like the clamd package is being updated from different directions. don't just "update" the whole lot. Check out the yum priorities plugin, and make epel a higher priority than rpmforge. then "upgrade" clamd to the version in epel and everythgin should then follow on OK.

chrism01 08-29-2012 07:24 AM

I'd like to know/check if this is RHEL or Centos eg

cat /etc/*release*
but it looks like you've got at least 3 repo sets defined: RHEL/Centos, epel, rpmforge.
Problem is they can conflict with each other.
Try installing yum-priorities rpm and setting eg Centos=5, epel=20, rf=30.
Personally I'd try to minimise repo sets.

snowweb 08-29-2012 07:46 AM

Thanks to both of you for that. Installing "priorities" appears to have solved my problems for now.

Unfortunately, much as I wanted to avoid using any third party repositories, I was unable to find a documented procedure capable of installing clamsmtp on CentOS6 with Postfix 2.6.x, without installing the extra repos. Probably didn't look in the right places, but I did devote a couple of days to it never the less. I hope because of that it's not going to give 3 years of pain!

Thanks again :-)

All times are GMT -5. The time now is 05:20 PM.