LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 03-17-2008, 01:46 AM   #1
mfdarvesh
LQ Newbie
 
Registered: Feb 2007
Posts: 21

Rep: Reputation: 15
Mysql on CentOS - Linux


I have installed CentOS 4.4 on my PC, I included mysql in installation
now, if I apply rpm -qa | grep -i mysql, it tells mysql and others, it mean that mysql has been installed, now how I can run mysql I tried following

service mysqld start (fail)
mysql (it says cannot connect to mysql)

please help me..
 
Old 03-17-2008, 01:52 AM   #2
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.10, Centos 7.3
Posts: 17,537

Rep: Reputation: 2420Reputation: 2420Reputation: 2420Reputation: 2420Reputation: 2420Reputation: 2420Reputation: 2420Reputation: 2420Reputation: 2420Reputation: 2420Reputation: 2420
You might need to be root to do that.
Or try a reboot.
There should be a start/stop/restart file in /etc/rc.d I think.
 
Old 03-17-2008, 02:07 AM   #3
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
service mysqld start is the correct command. As Chris said, make sure you are root or using sudo

Once you get it started, to have it automatically start on boot, as root type

chkconfig mysqld on

Last edited by billymayday; 03-17-2008 at 02:08 AM.
 
Old 03-17-2008, 02:20 AM   #4
mfdarvesh
LQ Newbie
 
Registered: Feb 2007
Posts: 21

Original Poster
Rep: Reputation: 15
These are the results of commands:
"
root@squid-server ~]# rpm -qa | grep -i mysql
mysqlclient10-3.23.58-4.RHEL4.1
perl-DBD-MySQL-2.9004-3.1
MySQL-python-1.0.0-1.RHEL4.1
mysql-devel-4.1.20-1.RHEL4.1
mysql-4.1.20-1.RHEL4.1
php-mysql-4.3.9-3.15
libdbi-dbd-mysql-0.6.5-10.RHEL4.1
"
[root@squid-server ~]# service mysqld start
mysqld: unrecognized service
"
following are found in /etc/rd.d/
drwxr-xr-x 2 root root 4096 Mar 17 10:44 init.d
-rwxr-xr-x 1 root root 2352 Mar 17 2004 rc
drwxr-xr-x 2 root root 4096 Mar 15 12:47 rc0.d
drwxr-xr-x 2 root root 4096 Mar 15 12:47 rc1.d
drwxr-xr-x 2 root root 4096 Mar 15 12:47 rc2.d
drwxr-xr-x 2 root root 4096 Mar 15 12:47 rc3.d
drwxr-xr-x 2 root root 4096 Mar 15 12:47 rc4.d
drwxr-xr-x 2 root root 4096 Mar 15 12:47 rc5.d
drwxr-xr-x 2 root root 4096 Mar 15 12:47 rc6.d
-rwxr-xr-x 1 root root 220 Jun 24 2003 rc.local
-rwxr-xr-x 1 root root 27584 Aug 13 2006 rc.sysinit
"

Plesae help me..
 
Old 03-17-2008, 02:43 AM   #5
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
You don't have the server installed!

yum install mysqld
 
Old 03-17-2008, 03:42 AM   #6
mfdarvesh
LQ Newbie
 
Registered: Feb 2007
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks, I apply the following:
[root@squid-server ~]# yum install mysqld
Setting up Install Process
Setting up repositories
update 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
addons 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 94 kB 00:32
update : ################################################## 291/291
Added 291 new packages, deleted 0 old in 2.92 seconds
primary.xml.gz 100% |=========================| 593 kB 04:56
base : ################################################## 1552/1552
Added 1552 new packages, deleted 0 old in 12.98 seconds
primary.xml.gz 100% |=========================| 157 B 00:00
Added 0 new packages, deleted 0 old in 0.01 seconds
primary.xml.gz 100% |=========================| 44 kB 00:29
extras : ################################################## 181/181
Added 181 new packages, deleted 0 old in 1.00 seconds
Parsing package install arguments
No Match for argument: mysqld
Nothing to do
'-------------- Service still not working, any thing more to do?
[root@squid-server ~]# service mysqld start
mysqld: unrecognized service
 
Old 03-17-2008, 04:13 AM   #7
vwvr9
Member
 
Registered: Feb 2005
Distribution: OpenSuse 10.1 / Centos 4.4
Posts: 60

Rep: Reputation: 15
yum install mysql-server that should work
 
Old 03-17-2008, 04:14 AM   #8
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Sorry - went off memory and got it wrong

It's

yum install mysql-server
 
Old 03-17-2008, 11:05 PM   #9
mfdarvesh
LQ Newbie
 
Registered: Feb 2007
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks VWVR9 and Billymayday, command is currently downloaning mysql lets' see results.
 
Old 03-17-2008, 11:45 PM   #10
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Let us know how you go
 
Old 03-18-2008, 02:22 AM   #11
mfdarvesh
LQ Newbie
 
Registered: Feb 2007
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks, Billymayday, I am able to install Mysql and working now and command, #service mysqld start is working, if you are so kind to me, please guide me, I want to connect windows xp client to mysql through ODBC, I installed ODBC 3.51 on windows xp machine, when I create DSN it says "clientxp.lan is not allowed to connect this server" "clientxp" is name of xp machine. Meanwhile ping "192.168.1.95" an IP address of server is working fine. Please suggest some things?
 
Old 03-18-2008, 02:36 AM   #12
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
I'm hopeless on mysql.

Since your initial problem is solved, start a new thread with a suitable title to get better attention than using an old thread.


Good luck
 
Old 03-18-2008, 02:42 AM   #13
mfdarvesh
LQ Newbie
 
Registered: Feb 2007
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks, starting new
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Centos 5, Apache, php, mysql Anauj0101 Linux - Server 5 02-26-2008 10:39 PM
Where are the database files for mysql in Centos 5? Anauj0101 Linux - Server 5 02-23-2008 05:39 PM
CentOS 5: postfix with mysql Berhanie Linux - Server 1 11-10-2007 08:05 AM
Mysql problem on CentOS gubak Linux - General 3 07-30-2007 06:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 02:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration