-   Linux - Server (
-   -   ModProxy and VirtualHost Combination Issue - Apache 2 (

ddenton 03-31-2009 02:13 PM

ModProxy and VirtualHost Combination Issue - Apache 2
I have an Apache 2 server on RHEL, configured to host a static website and also an ssl virtual host configured to act as an SSL proxy for some java processes on the same box.

What I'd like to do is use the same setup to proxy for a non-ssl virtual host on the same Apache installation. The problem is, I get "Data Transfer Interrupted" messages in the browser and the following in my error and access logs, respectively:


[Tue Mar 31 14:03:31 2009] [error] [client] Invalid method in request \x80O\x01\x03 - - [31/Mar/2009:14:03:31 -0500] "\x80O\x01\x03" 501 206 "-" "-"

To test, I have successfully set up a second Apache installation on the same box (listening on port 8800), and have used the appropriate proxypass and proxypassreverse directives in my ssl virtual host to proxy for it, so I'm wondering if the problem is trying to have Apache listen on 443 and proxy for port 8800 hosted by the same Apache instance?

Please forgive the lack of details configs. If I get a "yes, it's possible..." I'll gladly supply config examples...

Any help is greatly appreciated.

maddentim 04-01-2009 09:20 AM

I am having similar troubles with a website that I am working. The SSL sites were working fine until yesterday, then I started getting these data transfer interrupted errors. I have spent several hours of time troubleshooting to no avail. Nothing interesting coming up in the logs so far even though I have apache on loglevel debug...

I have tried numerous things and rebuilt parts but no fix yet. I am looking at the firewall now. I upgraded the OpenSSL package and rebooted the server yesterday too so that is suspicious. maybe a service i need did not come back or a security fix has caused my apache ssl not to work...

I will post if I find a fix...

ddenton 04-02-2009 05:20 PM

Thanks for the reply Madd, however I'm pretty sure the problem isn't related to the SSL cert in this case. I could be wrong, but like I said in my original post, having two separate instances of apache running on the same host with one proxying through the other worked fine.

I only saw the issues when the target apache installation was a virtual host to the main apache installation doing the proxying.

All times are GMT -5. The time now is 12:26 PM.