-   Linux - Server (
-   -   Missing ifcfg file after replacing nic (

xzased 01-05-2011 07:00 PM

Missing ifcfg file after replacing nic
I have 2 10gb fiber cards on a server running red hat 5.3, eth4 and eth5. After replacing the eth4 card, it doesnt show up any ifcfg-eth4 file. I tried ifconfig -a, but it doesnt show up in modprobe.conf either, although it is listed when I do a lspci. Should I manually add it? or is there something Im missing here? Thanks

jschiwal 01-05-2011 07:06 PM

Is the new card different? Start by checking the manufactures ID using "lspci -n". It might be a newer device that your present kernel version doesn't detect. I had that happen after I bought my netbook. I knew it used an Atheros wireless device, but the manid didn't match what the ath9k module looked for.

xzased 01-05-2011 07:28 PM

The new card is the same model as the one that got replaced, is the same as eth5 also. Here is the lspci output:

0e:00.0 Ethernet controller: Intel Corporation 82598EB 10 Gigabit AF Network Connection (rev 01)
12:00.0 Ethernet controller: Intel Corporation 82598EB 10 Gigabit AF Network Connection (rev 01)

lspci -n on these devices:

0e:00.0 0200: 8086:10c7 (rev 01)
12:00.0 0200: 8086:10c7 (rev 01)

bobloblian 01-05-2011 07:43 PM

in my experience, replacing a card makes it take the next eth number available. so replacing eth4 would create an eth6, and if you replaced eth5, it would come up as eth7. but that is just my experience...

xzased 01-05-2011 07:48 PM

But it should show up in modprobe.conf? Here is my output. I haven't touched the config so eth4 still shows up as the master (I have the 2 nics bonded)

alias eth0 e1000e
alias eth1 e1000e
alias eth2 e1000e
alias eth3 e1000e
alias eth6 bnx2
alias eth7 bnx2
alias eth8 bnx2
alias eth9 bnx2
alias scsi_hostadapter megaraid_sas
alias scsi_hostadapter1 ata_piix
alias bond0 bonding
options bond0 miimon=100 updelay=200 primary=eth4 mode=1
alias eth5 ixgbe

xzased 01-10-2011 08:26 PM

I solved this by checking the output of lspci to grab the bus id and then checking dmesg for the listed bus, which contained the mac address for the card. I then manually put it as eth4 on modprobe.conf and created an ifcfg-eth4 file in /etc/sysconfig/network-scripts/. It is working with no issues.

All times are GMT -5. The time now is 08:44 PM.