-   Linux - Server (
-   -   / LVM mounting read-only, how to mount read-write (

thllgo 11-09-2010 11:16 AM

/ LVM mounting read-only, how to mount read-write
I have a system using LVM and / is full and mounting read-only. How do I get it mounted read-write so I can delete some files?

I don't normally use LVM but this system has it. When the system boots it mounts / as read-only. I tried the "mount -o remount,rw /" but that command apparently doesn't work on LVM since there is no standard / entry in the fstab. I tried booting off a rescue disk and it didn't recognize the / partition so I tried to do a "mount /dev/sda8 -t lvm /mnt/sysimage/tmp" that didn't work either. I've been searching the web but I'm guessing I don't know enough about LVM to know what to search for.

Thank you for any help.

davinders 11-10-2010 03:47 AM


It was due to high I/O on / partition so best is restart the machine or

use the below options & try...

umount -f -l

JZL240I-U 11-10-2010 07:39 AM

Usually root has about 5% "grace" in the file system. So when a normal user gets stopped like you did, root should still be fine.

All times are GMT -5. The time now is 01:37 AM.