Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Server
User Name
Linux - Server This forum is for the discussion of Linux Software used in a server related context.


  Search this Thread
Old 02-12-2008, 11:42 AM   #1
Registered: Dec 2005
Location: NY, USA
Distribution: Ubuntu
Posts: 44

Rep: Reputation: 16
Looking for a particular FTP server...

I'm looking for an ftp server that can accept anonymous logins as either anonymous or ftp, and the user must input a password of at least "@", but it can be a full email address. Aka, the password cannot be blank and it must contain at least the "@" sign. And I would prefer if it had PAM support.

So allowed user/pass combos would be:

I've tried VSFTPD, ProFTPD, and Pure-FTPD but I cannot find any option to have a regex style password; it's either no password or password of a user account. Thanks for any input!
Old 02-12-2008, 12:27 PM   #2
Registered: Jul 2003
Location: Miami, Florida, USA
Distribution: Debian
Posts: 848
Blog Entries: 1

Rep: Reputation: 47
Try playing with /etc/pamd.d/ or /etc/pam.d/vsftpd - you will need to put entries in there to specify the requirements for the password.
Old 02-13-2008, 10:32 AM   #3
Registered: Dec 2005
Location: NY, USA
Distribution: Ubuntu
Posts: 44

Original Poster
Rep: Reputation: 16
ProFTPD for the friggin win! I just found a very nice configuration option...

It accepts RegEx Thanks anyway!
Old 02-16-2008, 05:53 PM   #4
Registered: Dec 2005
Location: NY, USA
Distribution: Ubuntu
Posts: 44

Original Poster
Rep: Reputation: 16
Well, I had some issues with AnonRejectPasswords.. it would not work with [^@], but any other character it would work with... so I changed the behavior of AnonRejectPasswords Just thought I'd share so anybody else who may have a similar issue could benefit. This was on an FC6 install btw.

Download current ProFTPD release (at the time of this writing, 1.3.1;
tar xf proftpd-1.3.1.tar.gz
cd proftpd-1.3.1
./configure --enable-autoshadow
Open modules/mod_auth.c (Edit line 836. 1.3.1 it looks like
((re_res = regexec(pw_regex, pass, 0, NULL, 0)) == 0)) {
Change the == to != and save the file.)
make install
Edit /usr/local/etc/proftpd.conf
Change the user and group to "ftp"
Add "PersistentPasswd off" after Port (this was necessary for my NIS authentication)
Add "AnonRejectPasswords @" in the Anonymous ftp section.
Change the <Anonymous ~/ftp> to whatever directory you want your anonymous stuff served from, ie <Anonymous /pub>.
Save, run proftpd! (I added mine to /etc/rc.local, but I know there are service scripts out there to handle it better.)

That's all


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
In plesk , I wish to have a backup cron job, ftp back up file to another ftp server? muskiediver Linux - General 6 07-16-2009 03:13 AM
files not visible in ftp site (but present in the /var/ftp/folder of the server) dongrila Linux - Newbie 2 12-23-2007 10:09 PM
ftp server - Pure ftp - logs in OK but no files visible tp11235 Linux - Networking 2 08-30-2005 05:11 AM
FTP Server Up and running... how do I hide ftp users from local login screen? joe1031 Mandriva 2 03-18-2005 04:24 PM
how can I restrict ftp users listing files from a pure-ftp server adrianmak Linux - Networking 2 12-31-2002 08:23 AM > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 08:37 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration