LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 08-13-2014, 08:51 AM   #1
trentham
LQ Newbie
 
Registered: Aug 2004
Location: Derbyshire, England
Distribution: Ubuntu, CentOS
Posts: 16

Rep: Reputation: 0
locales won't install due to dependance problems


I was first alerted to a problem on this Ubuntu server (12.04) when I got an error of
Code:
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_GB:",
        LC_ALL = (unset),
        LANG = "en_GB.UTF-8"
    are supported and installed on your system.
This led me to examine the locales set up and found there seemed to be no locales package installed...
Code:
> dpkg --get-selections | grep locales
krb5-locales                                    install
locales                                         deinstall
When I tried to install it I got...
Code:
> apt-get install locales
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  locales: Depends: libc6 (>= 2.9-0ubuntu10) but it is not going to be installed or
                    libc6.1 (>= 2.9-0ubuntu10) but it is not installable
E: Broken packages
So it seems to be complaining about libc6, although a check shows
Code:
> dpkg --get-selections | grep libc6
libc6                                           install
libc6-dev                                       install
I'm now out of my depth! I'm not sure exactly what it's trying to tell me or, more importantly, how I go about fixing it. Any assistance gratefully received!
 
Old 08-13-2014, 08:56 AM   #2
Guttorm
Senior Member
 
Registered: Dec 2003
Location: Trondheim, Norway
Distribution: Debian and Ubuntu
Posts: 1,317

Rep: Reputation: 350Reputation: 350Reputation: 350Reputation: 350
Hi

Things like this can happen if you don't run apt-get update and apt-get upgrade and you try to install some new package. It depends on newer versions and you havent't upgraded yet.

Try these commands first:

Code:
apt-get update
apt-get upgrade
apt-get install
 
Old 08-13-2014, 05:12 PM   #3
trentham
LQ Newbie
 
Registered: Aug 2004
Location: Derbyshire, England
Distribution: Ubuntu, CentOS
Posts: 16

Original Poster
Rep: Reputation: 0
I ran those commands and it seemed to do some cleaning and upgrading, then I ran the attempted install of locales but got exactly the same result.
 
Old 08-14-2014, 04:04 AM   #4
Guttorm
Senior Member
 
Registered: Dec 2003
Location: Trondheim, Norway
Distribution: Debian and Ubuntu
Posts: 1,317

Rep: Reputation: 350Reputation: 350Reputation: 350Reputation: 350
It sounds like it's "halfway" upgraded.

Does the command "apt-get install" give any error messages? You might need to do "apt-get -f install" if it does. Also check what you have in the file "/etc/apt/sources.list". Is it all 12.04? Version 2.9 is very old. And it seems you are using an older version than that. Running "apt-get dist-upgrade" should upgrade libc to a newer version.
 
Old 08-15-2014, 06:11 AM   #5
trentham
LQ Newbie
 
Registered: Aug 2004
Location: Derbyshire, England
Distribution: Ubuntu, CentOS
Posts: 16

Original Poster
Rep: Reputation: 0
apt-get install gives the following...
Code:
# apt-get install
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  python-debian aptitude libsigc++-2.0-0c2a libcwidget3 libboost-iostreams1.46.1 python-xapian apt-xapian-index libxapian22 python-chardet
  libept1.4.12
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
 
Old 08-18-2014, 08:17 AM   #6
trentham
LQ Newbie
 
Registered: Aug 2004
Location: Derbyshire, England
Distribution: Ubuntu, CentOS
Posts: 16

Original Poster
Rep: Reputation: 0
OK, since this seems to have the community stumped, is there any way I can install the locales package manually?
 
  


Reply

Tags
dependancies, libc6, locale


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB won't install--due to ata enumeration? darins Fedora 8 02-05-2008 11:52 PM
Yum won't install due to dependencies, NOT shown in deplist bonegang Linux - Newbie 6 06-27-2007 06:52 AM
dpkg dependance problems badgerbox76 Linux - Software 2 04-16-2006 06:01 AM
Scared to install FC2 (due to these dual-boot problems). XD Cesar Ocasio Fedora - Installation 3 06-12-2004 01:56 PM
SuSE problems; Mouse doesn't work, Wine won't install, WM won't install... Konig Linux - Distributions 1 01-21-2004 11:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 02:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration