-   Linux - Server (
-   -   Linux raid / md127 (

pika 10-28-2009 02:59 PM

Linux raid / md127

Last week I added a fourth disk to my RAID 5 setup using the guide on

Unfortunately, I forgot to update my /etc/mdadm.conf and rebooted like that.

Now, the raid set is identified as /dev/md127.


[root@mastodon ~]# mdadm --detail --scan --verbose
ARRAY /dev/md127 level=raid5 num-devices=4 metadata=0.90 UUID=d28897fc:8da6f8ef:bc01692b:1adecf8d

What should I do to make it appear as /dev/md0 again ? Can I simply modify /etc/mdadm.conf so it reads ARRAY /dev/md0.... or do I have to issue mdadm commands ?

System info:

[root@mastodon ~]# uname -a
Linux mastodon #1 SMP Thu Aug 27 21:34:36 EDT 2009 i686 i686 i386 GNU/Linux


[root@mastodon ~]# mdadm --version
mdadm - v3.0-devel3 - 10th March 2009

I also should add that this is just a naming issue, I can mount /dev/md127 fine and I can reach my data.

Thanks in advance,

mengoshmink 10-30-2013 05:01 PM

This is a similar problem to one I just experienced, I solved it by reading here:

And for more information this:

Specifically I ran:

mdadm --detail --scan >> /etc/mdadm.conf

robertjinx 11-03-2013 01:33 PM

Just run:


echo 'DEVICES /dev/sd* /dev/hd*' > /etc/mdadm.conf
mdadm -Es >> /etc/mdadm.conf

All times are GMT -5. The time now is 08:10 AM.