-   Linux - Server (
-   -   linux ppp client fails to connect to linux pptpd serve, works with windows vpn server (

wastingtime 09-19-2008 07:11 PM

SOLVED: linux ppp won't connect to linux pptpd server, works with windows vpn
I have two VPN servers
- linux pptpd (ppp 2.4.3) on centos4 configured to work with winodws vpn clients (i.e. ms-chap v2 + mppe 128)
- Windows 2003 VPN server

And two VPN clients
- linux pppd (2.4.3) on PClinuxOS configured to connect to windows VPN server
- Windows XP machine

The windows XP clinet connects to both servers with no issues, and
the linux client connect to the Windows VPN server with no issues

However the linux client fails to connect to the lonux vpn server!

teruzzi 09-20-2008 08:30 AM

Hello, where are your vpn client and vpn server pakcages coming from?
Distribution, open .org organisation?


wastingtime 09-20-2008 11:59 AM

Client: PCLinuxOS
RPM: ppp-2.4.3-13pclos2007
# pppd --version
pppd version 2.4.3
# pptp --version
pptp version 1.7.1

Server: CentOS
RPMs: ppp-2.4.3-5.rhel4 pptpd-1.3.0-0 kernel_ppp_mppe-1.0.2-3dkms
# pppd --version
pppd version 2.4.3
# pptpd --version
pptpd v1.3.0

wastingtime 09-20-2008 09:13 PM

I forgot to mention one detail, which turned out to be the issue:

I was first tunneling through a windows VPN, then connecting to the linux pptpd server.
Using the windows client the 2nd vpn (to the linux server) worked fine through the first VPN (to the windows server)

Using the linux client it didn't. It look like the Windows VPN server trashes the nested vpn communication when using the linux client

All times are GMT -5. The time now is 06:23 PM.