LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   LDAP auth with apache doesn't works in FC6 (https://www.linuxquestions.org/questions/linux-server-73/ldap-auth-with-apache-doesnt-works-in-fc6-506170/)

chithu 11-30-2006 05:06 AM

LDAP auth with apache doesn't works in FC6
 
Hi,

I have installed openldap-2.3.19-4 and apache httpd-2.2.0-5.1.2 in my Fedora 5 server. The same thing i tried with Fedora 6 server but no improvement.

Note:
But its works fine in Fedora 3 server. (openldap-2.2.29-1.FC3
and httpd-2.0.52-3)

When i am trying to do a ldap authenticate before displaying webpage. It asks username & password but it doesn't get through even if its a valid username & password.

Since the same config using in Fedora 3 works and not in Fedora 5 or Fedora 6. I wondering why its not working with latest versions of openldap & httpd. Is that any configurations are changed ?

Help is appreciated. Thanks in advance.


For your reference,

The /var/log/httpd error says,
[Thu Nov 30 16:27:23 2006] [error] [client 192.168.10.5] access to /testauth failed, reason: verification of user id 'chithu' not configured


My LDAP part in /etc/httpd/conf/httpd.conf files is

<Location /testauth>
AuthType Basic
AuthName "LDAP Authentication"
AuthLDAPURL "ldap://127.0.0.1:389/ou=people,dc=example,dc=com?uid"
Require valid-user
</Location>
-----

And my ldap server has following entries.

dn: dc=example,dc=com
dc: example
o: Organization
objectClass: dcObject
objectClass: organization
description: My Organization
----
dn: ou=people,dc=example,dc=com
ou: people
description: All employess of the Oraganization
objectclass: organizationalunit
----
dn: uid=test,ou=people,dc=example,dc=com
uid: test
cn: test
sn: test
userPassword: secret
objectClass: inetOrgPerson

----

bathory 11-30-2006 09:43 AM

Make sure you've loaded the mod_auth_ldap module? Check for something like the following in your httpd.conf:
Code:

LoadModule mm_auth_ldap_module modules/mod_auth_ldap.so

chithu 12-07-2006 02:02 AM

Hi,

Thanks for the reply.


LoadModule mm_auth_ldap_module modules/mod_auth_ldap.so

This module is available for older versions say httpd-2.0.52-3 on Fedora 3. And its not available for Fedora 5 or higher.


And I hope for the latest versions say httpd-2.2.0-5.1.2 on Fedora5 has the following modules related to LDAP.

LoadModule ldap_module modules/mod_ldap.so
LoadModule authnz_ldap_module modules/mod_authnz_ldap.so


Any thoughts please let me know.

Thanks,
M.Chidambaram.

bathory 12-07-2006 03:49 AM

According to mod_authnz_ldap documentation you need to add some more things in the ldap part of your configuration:
Code:

<Location /testauth>
AuthType Basic
AuthName "LDAP Authentication"
AuthBasicProvider ldap
AuthLDAPURL ldap://127.0.0.1:389/ou=people,dc=example,dc=com?uid
AuthzLDAPAuthoritative Off
Require valid-user
</Location>

Note also that you don't need the double quotes in your AuthLDAPURL

Regards

chithu 12-18-2006 05:19 AM

LDAP auth with apache doesn't works in FC6 Reply to Thread
 
<B>Thanks Bathory</B>

Problem is solved and its works perfectly.

chilon 03-08-2007 05:34 AM

problem group ldap + httpd
 
I used LDAP web authentification and it work with me and this my code:

<Location /ebiz>
DAV svn
SVNPath /var/opt/ebiz
AuthType Basic
Allow from all
AuthBasicProvider ldap
Options Indexes FollowSymLinks
AuthName "EBIZ Referentiel Subversion"
AuthLDAPUrl "ldap://192.168.0.1:389/ou=Users,dc=businessdecision,dc=com?uid"
AuthzLDAPAuthoritative Off
require ldap-user aoueslati mmedini rbensmida sbelhadj ychelly
</Location>

Now, I want to use auhtentification LDAP Group
In ower case group (ou=Groups)is EBIZ(cn=EBIZ)contain mmedini rbensmida sbelhadj ychelly (memberUid)

Please what can I Do??

Merci.

chithu 04-17-2007 03:45 AM

Hi,

I hope this link will help u, http://httpd.apache.org/docs/2.2/mod....html#reqgroup


Chidambaram.


All times are GMT -5. The time now is 08:55 PM.