-   Linux - Server (
-   -   L2TP/IPSec/openswan server for iphone help (

ShadowHywind 01-23-2010 05:00 PM

L2TP/IPSec/openswan server for iphone help
I am trying to setup a vpn client for my iphone since it doesn't support openvpn. However I keep running into this error message: initial Main Mode message received on <local ip>:500 but no connection has been authorized with policy=PSK
Any one have any ideas. I followed these directions (copying and pasting everything in). Any help would be great

affinity 01-25-2010 06:31 AM

Are you trying to connect to the VPN from the same LAN? I don't know if this applies to all VPN connections, but with the solution we have you can't authenticate if you are on the same physical network. I'm going to read through the Openswan documentation, I haven't heard of it before and I will actually be needing a Linux IPSec solution in the next few weeks so thanks for the post even though it's because you were having problems :) I will try to have a better answer for you after I finish reading.

Edit: Unless I am missing something obvious, which very well could be, I believe that my original thoughts are correct. Since VPN is a tunneling protocol it does not appear to be possible for a tunnel to be made while you are on the same physical network. Hopefully someone with a greater expertise in this area can confirm or deny this. Then again I don't even know if you were trying to connect from the same network or not to begin with, so this entire post may just be a waste of your time.

ShadowHywind 01-25-2010 09:10 AM

At first, I know I was trying to connect from within the network. But then tried connecting outside the network and the same error message as well.

affinity 01-25-2010 04:31 PM

When you copied and pasted the configuration files did you replace the values with your actual addresses?

All times are GMT -5. The time now is 01:29 PM.