LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   Kernel Error echo 0 > /proc/sys/kernel/hung _task_timeout_secsin Redhat 5.8 (https://www.linuxquestions.org/questions/linux-server-73/kernel-error-echo-0-proc-sys-kernel-hung-_task_timeout_secsin-redhat-5-8-a-4175432693/)

LittleMaster 10-17-2012 09:05 AM

Kernel Error echo 0 > /proc/sys/kernel/hung _task_timeout_secsin Redhat 5.8
 
Hi
I have the problem with with 2.6.18-308.el5 kernel release in Redhat release 5.8.The system get frequent hangs ,I had raised the ticket to redhat support regarding the kernel issue.

Redhat give the RFC report

They had replied the problem is not with kernel issue,the problem is with I/o ERROR leads with system crash.I could not get clear idea whether is my application error are system error.

Any help regarding these how can i set the parameter hung_task_timeout_secs" in kernel.What does the function does if i disable hung_task_timeout_secs to Zero.


[root@localhost ~]# cat /etc/issue RedHat Enterprise Linux Server release 5.8 (Tikanga)
Kernel \r on an \m

#uname -a
Linux localhost.localdomain 2.6.18-308.el5 #1 SMP Fri Jan 27 17:21:15 EST 2012 i686 i686 i386 GNU/Linux



** Kernel log: cat /var/log/messages

INFO: task kjournald:5479 blocked for more than 120 seconds.
"echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.

blueh2o 10-18-2012 09:32 AM

You can set the parameter in sysctl.conf to make it persistent, but all it does is disable the warning when a task blocks for more than 2 minutes. I've seen this before as a symptom when an application was opening database connections but not closing them. All the memory on the system was used up, and either kjournald or firebird would block, generating the warning.


All times are GMT -5. The time now is 07:13 AM.