LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 05-24-2008, 10:16 AM   #1
magnumbi
LQ Newbie
 
Registered: May 2005
Distribution: slackware, freebsd
Posts: 6

Rep: Reputation: 1
Issue with Cups and https


Hi,
I am having an issue on my home network with my server and cups. I have cupsd.conf configured to allow my laptop (the server and laptop have fixed IP's) to administer the cups configuration remotely. The problem I run in to is that whenever I try to save a change to the config file via the cups web interface, it tries to redirect me to "https" rather than "http". Because this is my home network I am not concerned with encryption when it comes to printing. Below is my cupsd.conf file. I thought that by setting "Encryption Required" to "Encryption Never" it would take care of the problem but apparently not.

This is running on Slackware 21.1. Any ideas as to how to correct this?
Code:
LogLevel info
SystemGroup sys root
# Allow remote access
Port 631
Listen /var/run/cups/cups.sock
# Share local printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAddress @LOCAL
DefaultAuthType Basic
<Location />
  Allow 192.168.2.*
  # Allow shared printing and remote administration...
  Order allow,deny
  Allow @LOCAL
</Location>
<Location /admin>
  Encryption Never
  Allow 192.168.2.3
  # Allow remote administration...
  Order allow,deny
  Allow @LOCAL
  Allow 192.168.2.3
</Location>
<Location /admin/conf>
  AuthType Default
  Require user @SYSTEM
  # Allow remote access to the configuration files...
  Order allow,deny
  Allow @LOCAL
</Location>
<Policy default>
  <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>
  <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>
  <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>
  <Limit Cancel-Job CUPS-Authenticate-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>
  <Limit All>
    Order deny,allow
  </Limit>
</Policy>
Thanks,
Brian
 
Old 05-24-2008, 07:39 PM   #2
magnumbi
LQ Newbie
 
Registered: May 2005
Distribution: slackware, freebsd
Posts: 6

Original Poster
Rep: Reputation: 1
Never mind. I was able to correct the problem by adding a line to the cupsd.conf file:

Code:
# Default authentication type, when authentication is required…
DefaultAuthType Basic
to

Code:
# Default authentication type, when authentication is required…
DefaultAuthType Basic
DefaultEncryption IfRequested
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
HTTPS/HTTP Authentication Issue win32sux LQ Suggestions & Feedback 4 03-05-2007 11:45 PM
cups-1.2.0 issue when compiling kde-3.5.2 tony yu Fedora 2 05-27-2006 04:57 AM
HP cups issue solved Bl4cKP3nGu1n Linux - Hardware 0 06-16-2005 04:13 AM
Cups Printing Issue Bigun Linux - Software 9 04-05-2005 10:39 PM
CUPS Configuration Issue Crashed_Again Linux - Software 3 01-21-2003 05:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 08:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration