LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 07-26-2008, 11:14 AM   #1
Valkyr1e
LQ Newbie
 
Registered: Jul 2008
Location: Earth
Distribution: Debian/Kubuntu
Posts: 12

Rep: Reputation: 0
Question ISC dhcp3 (ver. 3.04) vlan setup giving out of improper subnet addresses


Hello, this is my first post here, I have used LQ many times in the past to find answers to whatever problem I seem to have caused in learning how to use Linux. I thank you all for all those good posts! Until now I have not had a good reason to post since the answer was already there. So, anyway, on with the post!

I have an inter-vlan routing setup with the router (host-based by Debian 4.0r3 with Quagga performing dynamic routing) providing Dhcp to all vlans.
The box(Arm1tage) itself is hooked up to two 24 port cisco 2924XL-EN switches cascaded. The problem is that everytime Dhcp assigns an address it comes from the right subnet that the server listens on but it gives an address from the wrong subnet/vlan. I looked around on google and so far all the solutions are all based on giving the dhcp the MAC for all machines. I just want to be able to hook up a new client, have it get it's address and be up and running without the hassle of host statements. I will also include all pertinent networking information just in case it's the underlying the network that is causing the problem. I'm pretty certain though that it's a configuration problem with the dchp server. The daemon itself starts up just fine, no problems:


Jul 26 09:12:32 Arm1tage dhcpd: Internet Systems Consortium DHCP Server V3.0.4
Jul 26 09:12:32 Arm1tage dhcpd: Copyright 2004-2006 Internet Systems Consortium.
Jul 26 09:12:32 Arm1tage dhcpd: All rights reserved.
Jul 26 09:12:32 Arm1tage dhcpd: For info, please visit
Jul 26 09:12:32 Arm1tage dhcpd: Wrote 5 leases to leases file.
Jul 26 09:12:32 Arm1tage dhcpd: Multiple interfaces match the same shared network: eth3.2 eth3.3
Jul 26 09:12:32 Arm1tage dhcpd: Multiple interfaces match the same shared network: eth3.2 eth3.4
Jul 26 09:12:32 Arm1tage dhcpd: Multiple interfaces match the same shared network: eth3.2 eth3.5
Jul 26 09:12:32 Arm1tage dhcpd: Multiple interfaces match the same shared network: eth3.2 eth3.6
Jul 26 09:21:04 Arm1tage dhcpd: DHCPDISCOVER from 00:0b:db:7f:71:65 via eth3.3
Jul 26 09:21:05 Arm1tage dhcpd: DHCPOFFER on 11.1.9.254 to 00:0b:db:7f:71:65 (drizzt) via eth3.3
Jul 26 09:21:06 Arm1tage dhcpd: if drizzt.hiigara.hm IN A rrset doesn't exist add drizzt.hiigara.hm 43200 IN A 11.1.9.254: timed out.
Jul 26 09:21:06 Arm1tage dhcpd: DHCPREQUEST for 11.1.9.254 (11.1.2.1) from 00:0b:db:7f:71:65 (drizzt) via eth3.3
Jul 26 09:21:06 Arm1tage dhcpd: DHCPACK on 11.1.9.254 to 00:0b:db:7f:71:65 (drizzt) via eth3.3
Jul 26 09:22:20 Arm1tage dhcpd: DHCPINFORM from 11.1.9.254 via eth3.3
Jul 26 09:22:20 Arm1tage dhcpd: DHCPACK to 11.1.9.254 (00:0b:db:7f:71:65) via eth3.3
Jul 26 09:22:23 Arm1tage dhcpd: DHCPINFORM from 11.1.9.254 via eth3.3
Jul 26 09:22:23 Arm1tage dhcpd: DHCPACK to 11.1.9.254 (00:0b:db:7f:71:65) via eth3.3
Jul 26 09:24:01 Arm1tage dhcpd: DHCPINFORM from 11.1.9.254 via eth3.3
Jul 26 09:24:01 Arm1tage dhcpd: DHCPACK to 11.1.9.254 (00:0b:db:7f:71:65) via eth3.3
Jul 26 09:24:04 Arm1tage dhcpd: DHCPINFORM from 11.1.9.254 via eth3.3
Jul 26 09:24:04 Arm1tage dhcpd: DHCPACK to 11.1.9.254 (00:0b:db:7f:71:65) via eth3.3
Jul 26 09:25:43 Arm1tage dhcpd: DHCPINFORM from 11.1.9.254 via eth3.3
Jul 26 09:25:43 Arm1tage dhcpd: DHCPACK to 11.1.9.254 (00:0b:db:7f:71:65) via eth3.3
Jul 26 09:25:47 Arm1tage dhcpd: DHCPINFORM from 11.1.9.254 via eth3.3
Jul 26 09:25:47 Arm1tage dhcpd: DHCPACK to 11.1.9.254 (00:0b:db:7f:71:65) via eth3.3
Jul 26 09:27:25 Arm1tage dhcpd: DHCPINFORM from 11.1.9.254 via eth3.3
Jul 26 09:27:25 Arm1tage dhcpd: DHCPACK to 11.1.9.254 (00:0b:db:7f:71:65) via eth3.3
Jul 26 09:27:28 Arm1tage dhcpd: DHCPINFORM from 11.1.9.254 via eth3.3
Jul 26 09:27:28 Arm1tage dhcpd: DHCPACK to 11.1.9.254 (00:0b:db:7f:71:65) via eth3.3
Jul 26 09:47:23 Arm1tage dhcpd: DHCPDISCOVER from 00:d0:b7:ba:0e:38 via eth3.4
Jul 26 09:47:24 Arm1tage dhcpd: DHCPOFFER on 11.1.8.255 to 00:d0:b7:ba:0e:38 via eth3.4
Jul 26 09:47:24 Arm1tage dhcpd: DHCPREQUEST for 11.1.8.255 (11.1.4.1) from 00:d0:b7:ba:0e:38 via eth3.4
Jul 26 09:47:24 Arm1tage dhcpd: DHCPACK on 11.1.8.255 to 00:d0:b7:ba:0e:38 via eth3.4
Jul 26 09:52:54 Arm1tage dhcpd: DHCPDISCOVER from 00:d0:b7:ba:0e:38 via eth3.3
Jul 26 09:52:55 Arm1tage dhcpd: DHCPOFFER on 11.1.8.255 to 00:d0:b7:ba:0e:38 via eth3.3
Jul 26 09:52:55 Arm1tage dhcpd: DHCPREQUEST for 11.1.8.255 (11.1.2.1) from 00:d0:b7:ba:0e:38 via eth3.3
Jul 26 09:52:55 Arm1tage dhcpd: DHCPACK on 11.1.8.255 to 00:d0:b7:ba:0e:38 via eth3.3
Arm1tage:~#


Vlan 1 = default (management network)
Vlan 2 = Routed (11.1.0.0/23)
Vlan 3 = Games (11.1.2.0/23)
Vlan 4 = Mods (11.1.4.0/23)
Vlan 5 = Accounts(11.1.6.0/23)
Vlan 6 = Family (11.1.8.0/23)
Vlan 7 = Trunks (trunks get their own native vlan)

the topology(sorry my ASCII art is not so good) at it's simplest is:

Trunk Trunks
S1 /--\ S2
Arm1tage---------->Cisco 2900XL Cisco 2900XL
\_/
cat /proc/net/vlan/*

Arm1tage:~# cat /proc/net/vlan/*
VLAN Dev name | VLAN ID
Name-Type: VLAN_NAME_TYPE_RAW_PLUS_VID_NO_PAD
eth3.2 | 2 | eth3
eth3.3 | 3 | eth3
eth3.4 | 4 | eth3
eth3.5 | 5 | eth3
eth3.6 | 6 | eth3
eth3.2 VID: 2 REORDER_HDR: 1 dev->priv_flags: 1
total frames received 5378
total bytes received 307620
Broadcast/Multicast Rcvd 5369

total frames transmitted 1034
total bytes transmitted 98403
total headroom inc 0
total encap on xmit 1034
Device: eth3
INGRESS priority mappings: 0:0 1:0 2:0 3:0 4:0 5:0 6:0 7:0
EGRESSS priority Mappings:
eth3.3 VID: 3 REORDER_HDR: 1 dev->priv_flags: 1
total frames received 6905
total bytes received 394865
Broadcast/Multicast Rcvd 4463

total frames transmitted 977
total bytes transmitted 89141
total headroom inc 0
total encap on xmit 977
Device: eth3
INGRESS priority mappings: 0:0 1:0 2:0 3:0 4:0 5:0 6:0 7:0
EGRESSS priority Mappings:
eth3.4 VID: 4 REORDER_HDR: 1 dev->priv_flags: 1
total frames received 4478
total bytes received 242344
Broadcast/Multicast Rcvd 4449

total frames transmitted 975
total bytes transmitted 88449
total headroom inc 0
total encap on xmit 975
Device: eth3
INGRESS priority mappings: 0:0 1:0 2:0 3:0 4:0 5:0 6:0 7:0
EGRESSS priority Mappings:
eth3.5 VID: 5 REORDER_HDR: 1 dev->priv_flags: 1
total frames received 4452
total bytes received 241326
Broadcast/Multicast Rcvd 4449

total frames transmitted 973
total bytes transmitted 87757
total headroom inc 0
total encap on xmit 973
Device: eth3
INGRESS priority mappings: 0:0 1:0 2:0 3:0 4:0 5:0 6:0 7:0
EGRESSS priority Mappings:
eth3.6 VID: 6 REORDER_HDR: 1 dev->priv_flags: 1
total frames received 4442
total bytes received 239868
Broadcast/Multicast Rcvd 4442

total frames transmitted 997
total bytes transmitted 88861
total headroom inc 0
total encap on xmit 997
Device: eth3
INGRESS priority mappings: 0:0 1:0 2:0 3:0 4:0 5:0 6:0 7:0
EGRESSS priority Mappings:
Arm1tage:~#


Arm1tage:~# cat /etc/init.d/rc.local
#! /bin/sh
### BEGIN INIT INFO
# Provides: rc.local
# Required-Start: $local_fs $remote_fs
# Required-Stop:
# Default-Start: 2 3 4 5
# Default-Stop:
# Short-Description: Run /etc/rc.local if it exist
### END INIT INFO

echo LOADING subnetted vlan interfaces on shared physical interface eth3
modprobe 8021q
ifconfig eth3 down
ifconfig eth3 up
vconfig add eth3 2
vconfig add eth3 3
vconfig add eth3 4
vconfig add eth3 5
vconfig add eth3 6
ifconfig eth3.2 11.1.0.1 netmask 255.255.254.0 up
ifconfig eth3.3 11.1.2.1 netmask 255.255.254.0 up
ifconfig eth3.4 11.1.4.1 netmask 255.255.254.0 up
ifconfig eth3.5 11.1.6.1 netmask 255.255.254.0 up
ifconfig eth3.6 11.1.8.1 netmask 255.255.254.0 up
echo LOADING complete

echo correct AND comment out 8021q statements in rc.local as time and patience allow
echo statements CORRECTED ugh

Arm1tage:~#


Arm1tage:~# vtysh

Hello, this is Quagga (version 0.99.5).
Copyright 1996-2005 Kunihiro Ishiguro, et al.

Arm1tage.hiigara.hm# show run
Building configuration...

Current configuration:
!
log stdout informational
log monitor informational
!
password zebra
password ospfd
!
interface eth0
ip address 192.168.4.2/27
ipv6 nd suppress-ra
link-detect
multicast
!
interface eth1
description To Elrond
ip address 192.168.4.54/29
ipv6 nd suppress-ra
link-detect
multicast
!
interface eth2
description To the Core of Gandalf
ip address 192.168.4.34/28
ipv6 nd suppress-ra
link-detect
multicast
!
interface eth3
description Gateway to Hiigara For the Lord
ipv6 nd suppress-ra
link-detect
multicast
!
interface eth3.2
description Routed
ip address 11.1.0.1/23
ipv6 nd suppress-ra
link-detect
multicast
!
interface eth3.3
description Games
ip address 11.1.2.1/23
ipv6 nd suppress-ra
link-detect
multicast
!
interface eth3.4
description Mods
ip address 11.1.4.1/23
ipv6 nd suppress-ra
link-detect
multicast
!
interface eth3.5
description Accounts
ip address 11.1.6.1/23
ipv6 nd suppress-ra
link-detect
no multicast
!
interface eth3.6
description Family
ip address 11.1.8.1/23
ipv6 nd suppress-ra
link-detect
no multicast
!
interface lo
ip address 120.0.0.0/32
link-detect
!
interface sit0
ipv6 nd suppress-ra
!
router-id 120.0.0.1
!
router ospf
ospf router-id 120.0.0.1
log-adjacency-changes detail
network 11.1.0.0/23 area 0.0.0.0
network 11.1.2.0/23 area 0.0.0.0
network 11.1.4.0/23 area 0.0.0.0
network 11.1.6.0/23 area 0.0.0.0
network 11.1.8.0/23 area 0.0.0.0
network 192.168.4.0/27 area 0.0.0.0
network 192.168.4.32/28 area 0.0.0.0
network 192.168.4.48/29 area 0.0.0.0
default-information originate always
!
ip route 0.0.0.0/0 192.168.4.1 190
!
ip forwarding
!
line vty
!
Arm1tage.hiigara.hm#

Arm1tage.hiigara.hm# show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
I - ISIS, B - BGP, > - selected route, * - FIB route

S 0.0.0.0/0 [190/0] via 192.168.4.1, eth0
K>* 0.0.0.0/0 via 192.168.4.1, eth0
O 11.1.0.0/23 [110/10] is directly connected, eth3.2, 02:31:23
C>* 11.1.0.0/23 is directly connected, eth3.2
O 11.1.2.0/23 [110/10] is directly connected, eth3.3, 02:31:23
C>* 11.1.2.0/23 is directly connected, eth3.3
O 11.1.4.0/23 [110/10] is directly connected, eth3.4, 02:31:23
C>* 11.1.4.0/23 is directly connected, eth3.4
O 11.1.6.0/23 [110/10] is directly connected, eth3.5, 02:31:23
C>* 11.1.6.0/23 is directly connected, eth3.5
O 11.1.8.0/23 [110/10] is directly connected, eth3.6, 02:31:23
C>* 11.1.8.0/23 is directly connected, eth3.6
C>* 120.0.0.0/32 is directly connected, lo
C>* 127.0.0.0/8 is directly connected, lo
O>* 172.16.0.8/30 [110/30] via 192.168.4.33, eth2, 02:31:19
O>* 172.17.8.0/29 [110/40] via 192.168.4.33, eth2, 02:31:19
O>* 192.168.3.0/24 [110/20] via 192.168.4.1, eth0, 02:31:23
O 192.168.4.0/27 [110/10] is directly connected, eth0, 02:31:28
C>* 192.168.4.0/27 is directly connected, eth0
O 192.168.4.32/28 [110/10] is directly connected, eth2, 02:31:23
C>* 192.168.4.32/28 is directly connected, eth2
O>* 192.168.4.64/30 [110/20] via 192.168.4.33, eth2, 02:31:19
Arm1tage.hiigara.hm#


This is S1's information:
IOS (tm) C2900XL Software (C2900XL-C3H2S-M), Version 12.0(5)WC17, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2007 by cisco Systems, Inc.
Compiled Tue 13-Feb-07 15:27 by antonino

User Access Verification

Password:
Password:
S1>en
Password:
S1#show run
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname S1
!
enable secret 5 $1$cXYN$I54yntdLL4PPf9zcqBfj2/
enable password cisco
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
description to Arm1tage
switchport trunk encapsulation dot1q
switchport trunk native vlan 7
switchport mode trunk
!
interface FastEthernet0/2
description to SSMB
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 2
!
interface FastEthernet0/3
description to Gandalf
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 2
!
interface FastEthernet0/4
description to Lindon
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 2
!
interface FastEthernet0/5
description to Glamdring
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 2
!
interface FastEthernet0/6
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 3
!
interface FastEthernet0/7
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 3
!
interface FastEthernet0/8
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 3
!
interface FastEthernet0/9
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 3
!
interface FastEthernet0/10
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 3
!
interface FastEthernet0/11
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 4
!
interface FastEthernet0/12
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 4
!
interface FastEthernet0/13
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 4
!
interface FastEthernet0/14
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 4
!
interface FastEthernet0/15
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 4
!
interface FastEthernet0/16
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 5
!
interface FastEthernet0/17
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 5
!
interface FastEthernet0/18
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 5
!
interface FastEthernet0/19
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 5
!
interface FastEthernet0/20
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 5
!
interface FastEthernet0/21
port security
port security max-mac-count 1
port security action shutdown
!
interface FastEthernet0/22
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 6
!
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport trunk native vlan 7
switchport mode trunk
!
interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport trunk native vlan 7
switchport mode trunk
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface VLAN1
ip address 192.168.11.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
ip default-gateway 192.168.11.1
mac-address-table secure 000c.308e.7ac0 FastEthernet0/5 vlan 2
!
line con 0
password cisco
login
transport input none
stopbits 1
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
end

S1#
this the end of part one
 
Old 07-26-2008, 11:15 AM   #2
Valkyr1e
LQ Newbie
 
Registered: Jul 2008
Location: Earth
Distribution: Debian/Kubuntu
Posts: 12

Original Poster
Rep: Reputation: 0
This is part two
S1#show vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/21, Fa1/1, Fa1/2
2 Routed active Fa0/2, Fa0/3, Fa0/4, Fa0/5
3 Games active Fa0/6, Fa0/7, Fa0/8, Fa0/9,
Fa0/10
4 Mods active Fa0/11, Fa0/12, Fa0/13, Fa0/14,
Fa0/15
5 Accounts active Fa0/16, Fa0/17, Fa0/18, Fa0/19,
Fa0/20
6 Family active Fa0/22
7 Trunks active
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
2 enet 100002 1500 - - - - - 0 0
3 enet 100003 1500 - - - - - 0 0
4 enet 100004 1500 - - - - - 0 0
5 enet 100005 1500 - - - - - 0 0
6 enet 100006 1500 - - - - - 0 0
7 enet 100007 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
S1#


And this is S2's configuration information:
Cisco Internetwork Operating System Software
IOS (tm) C2900XL Software (C2900XL-C3H2S-M), Version 12.0(5)WC16, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2006 by cisco Systems, Inc.
Compiled Thu 21-Sep-06 13:00 by antonino
S2#show run
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname S2
!
enable secret 5 $1$n5zE$uGaAQeDzO8taxUZzN8p3F/
enable password cisco
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 7
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport trunk native vlan 7
switchport mode trunk
!
interface FastEthernet0/3
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 6
!
interface FastEthernet0/4
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 6
!
interface FastEthernet0/5
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 6
!
interface FastEthernet0/6
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 3
!
interface FastEthernet0/7
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 3
!
interface FastEthernet0/8
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 3
!
interface FastEthernet0/9
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 3
!
interface FastEthernet0/10
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 3
!
interface FastEthernet0/11
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 4
!
interface FastEthernet0/12
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 4
!
interface FastEthernet0/13
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 4
!
interface FastEthernet0/14
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 4
!
interface FastEthernet0/15
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 4
!
interface FastEthernet0/16
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 5
!
interface FastEthernet0/17
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 5
!
interface FastEthernet0/18
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 5
!
interface FastEthernet0/19
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 5
!
interface FastEthernet0/20
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 5
!
interface FastEthernet0/21
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 6
!
interface FastEthernet0/22
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 6
!
interface FastEthernet0/23
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 6
!
interface FastEthernet0/24
port security
port security max-mac-count 1
port security action shutdown
switchport access vlan 6
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface VLAN1
ip address 192.168.11.3 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
ip default-gateway 192.168.11.1
mac-address-table secure 000b.db7f.7165 FastEthernet0/8 vlan 3
mac-address-table secure 00d0.b7ba.0e38 FastEthernet0/9 vlan 3
mac-address-table secure 00d0.b7ba.0e38 FastEthernet0/11 vlan 4
mac-address-table secure 00d0.b7ba.0e38 FastEthernet0/16 vlan 5
mac-address-table secure 00d0.b7ba.0e38 FastEthernet0/4 vlan 6
!
line con 0
password cisco
login
transport input none
stopbits 1
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
end

S2#


S2#show vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa1/1, Fa1/2
2 Routed active
3 Games active Fa0/6, Fa0/7, Fa0/8, Fa0/9,
Fa0/10
4 Mods active Fa0/11, Fa0/12, Fa0/13, Fa0/14,
Fa0/15
5 Accounts active Fa0/16, Fa0/17, Fa0/18, Fa0/19,
Fa0/20
6 Family active Fa0/3, Fa0/4, Fa0/5, Fa0/21,
Fa0/22, Fa0/23, Fa0/24
7 Trunks active
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
2 enet 100002 1500 - - - - - 0 0
3 enet 100003 1500 - - - - - 0 0
4 enet 100004 1500 - - - - - 0 0
5 enet 100005 1500 - - - - - 0 0
6 enet 100006 1500 - - - - - 0 0
7 enet 100007 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - srb 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
S2#

S2#show int status

Port Name Status Vlan Duplex Speed Type
------- ------------------ ------------ -------- ------ ------- ----
Fa0/1 connected trunk A-Full A-100 100BaseTX/FX
Fa0/2 connected trunk A-Full A-100 100BaseTX/FX
Fa0/3 notconnect 6 Auto Auto 100BaseTX/FX
Fa0/4 notconnect 6 Auto Auto 100BaseTX/FX
Fa0/5 notconnect 6 Auto Auto 100BaseTX/FX
Fa0/6 notconnect 3 Auto Auto 100BaseTX/FX
Fa0/7 notconnect 3 Auto Auto 100BaseTX/FX
Fa0/8 connected 3 A-Full A-100 100BaseTX/FX
Fa0/9 notconnect 3 Auto Auto 100BaseTX/FX
Fa0/10 notconnect 3 Auto Auto 100BaseTX/FX
Fa0/11 connected 4 A-Full A-100 100BaseTX/FX
Fa0/12 notconnect 4 Auto Auto 100BaseTX/FX
Fa0/13 notconnect 4 Auto Auto 100BaseTX/FX
Fa0/14 notconnect 4 Auto Auto 100BaseTX/FX
Fa0/15 notconnect 4 Auto Auto 100BaseTX/FX
Fa0/16 notconnect 5 Auto Auto 100BaseTX/FX
Fa0/17 notconnect 5 Auto Auto 100BaseTX/FX
Fa0/18 notconnect 5 Auto Auto 100BaseTX/FX
Fa0/19 notconnect 5 Auto Auto 100BaseTX/FX
Fa0/20 notconnect 5 Auto Auto 100BaseTX/FX

Port Name Status Vlan Duplex Speed Type
------- ------------------ ------------ -------- ------ ------- ----
Fa0/21 notconnect 6 Auto Auto 100BaseTX/FX
Fa0/22 notconnect 6 Auto Auto 100BaseTX/FX
Fa0/23 notconnect 6 Auto Auto 100BaseTX/FX
Fa0/24 notconnect 6 Auto Auto 100BaseTX/FX
Fa1/1 notconnect 1 Full 100 100BaseFX
Fa1/2 notconnect 1 Full 100 100BaseFX

S2#

I have two hosts one on vlan 3 the other on 4

they should get their addresses from the 11.1.2.0 and 11.1.4.0 subnets respectively but as you saw up above in the dhcp startup they don't!

here is the dhcpd.conf

Arm1tage:~# cat /etc/dhcp3/dhcpd.conf
ddns-updates on;
option netbios-node-type 8;
option netbios-name-servers 192.168.4.1;
option ntp-servers 192.168.4.1;
option domain-name-servers 192.168.4.2;
#
# Sample configuration file for ISC dhcpd for Debian
#
# $Id: dhcpd.conf,v 1.1.1.1 2002/05/21 00:07:44 peloy Exp $
#

# The ddns-updates-style parameter controls whether or not the server will
# attempt to do a DNS update when a lease is confirmed. We default to the
ddns-update-style ad-hoc;

option domain-name "hiigara.hm";

default-lease-time 86400;
max-lease-time 172800;

# If this DHCP server is the official DHCP server for the local
# network, the authoritative directive should be uncommented.
#authoritative;

# Use this to send dhcp log messages to a different log file (you also
# have to hack syslog.conf to complete the redirection).
log-facility local7;

# No service will be given on this subnet, but declaring it helps the
# DHCP server to understand the network topology.

#subnet 10.152.187.0 netmask 255.255.255.0 {
#}

# This is a very basic subnet declaration.

#subnet 10.254.239.0 netmask 255.255.255.224 {
# range 10.254.239.10 10.254.239.20;
# option routers rtr-239-0-1.example.org, rtr-239-0-2.example.org;
#}

# This declaration allows BOOTP clients to get dynamic addresses,
# which we don't really recommend.

#subnet 10.254.239.32 netmask 255.255.255.224 {
# range dynamic-bootp 10.254.239.40 10.254.239.60;
# option broadcast-address 10.254.239.31;
# option routers rtr-239-32-1.example.org;
#}

# A slightly different configuration for an internal subnet.
#subnet 10.5.5.0 netmask 255.255.255.224 {
# range 10.5.5.26 10.5.5.30;
# option domain-name-servers ns1.internal.example.org;
# option domain-name "internal.example.org";
# option routers 10.5.5.1;
# option broadcast-address 10.5.5.31;
# default-lease-time 600;
# max-lease-time 7200;
#}

# Hosts which require special configuration options can be listed in
# host statements. If no address is specified, the address will be
# allocated dynamically (if possible), but the host-specific information
# will still come from the host declaration.

#host passacaglia {
# hardware ethernet 0:0:c0:5d:bd:95;
# filename "vmunix.passacaglia";
# server-name "toccata.fugue.com";
#}

# Fixed IP addresses can also be specified for hosts. These addresses
# should not also be listed as being available for dynamic assignment.
# Hosts for which fixed IP addresses have been specified can boot using
# BOOTP or DHCP. Hosts for which no fixed address is specified can only
# be booted with DHCP, unless there is an address range on the subnet
# to which a BOOTP client is connected which has the dynamic-bootp flag
# set.
#host fantasia {
# hardware ethernet 08:00:07:26:c0:a5;
# fixed-address fantasia.fugue.com;
#}

# You can declare a class of clients and then do address allocation
# based on that. The example below shows a case where all clients
# in a certain class get addresses on the 10.17.224/24 subnet, and all
# other clients get addresses on the 10.0.29/24 subnet.

#class "foo" {
# match if substring (option vendor-class-identifier, 0, 4) = "SUNW";
#}

#shared-network 224-29 {
# subnet 10.17.224.0 netmask 255.255.255.0 {
# option routers rtr-224.example.org;
# }
# subnet 10.0.29.0 netmask 255.255.255.0 {
# option routers rtr-29.example.org;
# }
# pool {
# allow members of "foo";
# range 10.17.224.10 10.17.224.250;
# }
# pool {
# deny members of "foo";
# range 10.0.29.10 10.0.29.230;
# }
#}
# For the Lord locally
subnet 192.168.4.0 netmask 255.255.255.224 {
option subnet-mask 255.255.255.224;
option routers 192.168.4.1;
authoritative;
allow unknown-clients;
range 192.168.4.3 192.168.4.30;
}
# loopback
subnet 127.0.0.0 netmask 255.0.0.0 {
}
# core
subnet 192.168.4.32 netmask 255.255.255.240 {
option domain-name-servers 192.168.4.46 , 192.168.4.1;
option routers 192.168.4.34 , 192.168.4.1;
allow unknown-clients;
range 192.168.4.33 192.168.4.45;
}
# This is manned
shared-network Master {
authoritative;
# Main 2
subnet 11.1.0.0 netmask 255.255.254.0 {
option broadcast-address 11.1.1.255;
option routers 11.1.0.1;
range dynamic-bootp 11.1.0.10 11.1.1.254;
}
# Main 3
subnet 11.1.2.0 netmask 255.255.254.0 {
option broadcast-address 11.1.3.255;
authoritative;
allow unknown-clients;
option routers 11.1.2.1;
range dynamic-bootp 11.1.2.10 11.1.3.254;
}
# Main 4
subnet 11.1.4.0 netmask 255.255.254.0 {
option broadcast-address 11.1.5.255;
option routers 11.1.4.1;
authoritative;
allow unknown-clients;
range dynamic-bootp 11.1.4.10 11.1.5.254;
}
# Main 5
subnet 11.1.6.0 netmask 255.255.254.0 {
option broadcast-address 11.1.7.255;
option routers 11.1.6.1;
range dynamic-bootp 11.1.6.10 11.1.7.254;
}
# Main 6
subnet 11.1.8.0 netmask 255.255.254.0 {
option broadcast-address 11.1.9.255;
option routers 11.1.8.1;
range dynamic-bootp 11.1.8.10 11.1.9.254;
}
}
Arm1tage:~#

I would greatly appreciate any help yall can offer, please let me know if I missed any more information that would help.
-Valky1re
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
VLAN vs Subnet - too many ambiguous answers online Meson Linux - Networking 5 04-09-2008 04:35 PM
Binding 2 NICs (MAC addresses) to 2 IP Addresses in same Subnet RedHat EL4.0 skhira Linux - Networking 13 02-24-2008 08:16 PM
Binding 2 NICs (MAC addresses) to 2 IP Addresses in same Subnet RedHat EL4.0 skhira Linux - Networking 1 02-09-2008 07:17 AM
DHCP - Multiple range in 1 subnet??? - Debian Sarge 3.1, DHCP3.0 kenwoodgt Linux - Networking 1 01-24-2008 03:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 04:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration