-   Linux - Server (
-   -   'invalid method in request' - Apache & SSL on Centos (

scottmusician 09-04-2011 07:14 PM

'invalid method in request' - Apache & SSL on Centos
Hi everyone,

Ever since I have changed my Centos 5 server to work with HTTPS, I've not been able to view my locally stored webpages. Apache starts fine, but any attempts to access my webserver results in a "ssl_error_rx_record"too_long_" error in my browser, and in the Apache error log I get the error:
"[error] [client' invalid method in request \x16\x03\x01".

I know my SSL certificate is fine, because It's a signed one from GoDaddy and it works fine with other services (eg. 'telnet localhost smtp' works fine for my postfix configuration).

I read somewhere that if i type the following:

# telnet 443

and a bunch of HTML code is presented, then my mod_ssl module isn't loading. Indeed, this 'HTML dump' is what is happening to me. Further, I've also read some things about running an "a2ensite" command, but this appears only to be a debian thing???

Below are the important lines of my ssl.conf and httpd.conf. I've been stumped on this for a while, so any help would be wonderful!

Thanks again, Scott


Timeout 300
LoadModule ssl_module modules/
Include conf.d/*.conf
ServerAdmin root@localhost
<ifDefine SSL>
DocumentRoot /use/share/squirrelmail

SSLCertificateFile /etc/path/to/mydomain.crt
SSLCertificateKeyFile /etc/path/to/private/mydomain.key
SSLCertificateChainFile /etc/path/to/bundle.crt


Listen 443 https

SSLSessionCache none
SSLSessionCacheTimeout 300

bathory 09-05-2011 12:39 AM


You cannot use telnet to test https. Better use:

openssl s_client -connect 443
and then use the GET / HTTP/1.1, etc.

Also add a

NameVirtualHost *:443
in ssl.conf and use the following to define the ssl vhost

<VirtualHost *:443>
Note also that you have an error in the Listen directive. It should be

Listen 443

scottmusician 09-07-2011 07:55 AM

hey again!

Thanks for the advice, but i am still getting the same error when i attempt to access the https:// site.


# openssl s_client -connect
6957:error:140770FC:SSL outines:SSL23_GET_SERVER_HELLO:unknown protocol:s23_clnt.c:588:

just to confirm, my ssl.conf is now looking like this:

#LoadModule ssl_module modules/
Listen 443
NameVirtualHost *:443

<ifDefine SSL>
<VirtualHost *:443>
DocumentRoot /usr/share/squirrelmail
SSLCertificateFile /etc/pki/tls/certs/
SSLCertificateKeyFile /etc/pki/tls/private/
SSLCertificateChainFile  /etc/pki/tls/certs/my_godaddy_bundle.crt

thanks again :)

bathory 09-07-2011 08:42 AM


Somehow you're talking plain http to the ssl server. Why don't you load the mod_ssl module? And you have an error in ServerName (no need for :443 at the end)
Anyway, use the following and see if it works

LoadModule ssl_module modules/
Listen 443
NameVirtualHost *:443

<VirtualHost *:443>
DocumentRoot /usr/share/squirrelmail
SSLCertificateFile /etc/pki/tls/certs/
SSLCertificateKeyFile /etc/pki/tls/private/
SSLCertificateChainFile  /etc/pki/tls/certs/my_godaddy_bundle.crt


scottmusician 09-08-2011 12:44 AM

Sorry I forgot to mention that I was loading from httpd.conf. For completeness sake, I have included the whole httpd.conf file below.

Anyway, Good news! (well sort of). Removing the <ifDefine> tags has gotten rid of the invalid method request error. I'm still unable to view my SquirrelMail login page whenever i attempt to access (or , for that matter). Instead of the "rx_record_too_long_" I am now getting a different error:

The connection was interrupted. The connection to was interrupted while the page was loading.

and this is what happens when I do an openssl s_client -connect: :

31951:error:140790E5:SSL routines:SSL23_WRITE:ssl handshake failure:s23_lib.c:188:

There are no errors in /var/log/httpd/error_log, and the access_log simply says:
Code: - - [08/Sep/2011:15:03:49 +1000] "\x80@\x01\x03" 302 - "-" "-" - - [08/Sep/2011:15:06:21 +1000] "\x80w\x01\x03\x01" 302 - "-" "-"

interestingly, my SquirrelMail login page is loading (without SSL) if I visit . At least httpd is now restarting without errors...

Thanks again :)


ServerTokens OS
ServerRoot "/etc/httpd"
PidFile run/
Timeout 120
KeepAlive Off

MaxKeepAliveRequests 100
KeepAliveTimeout 15

<IfModule prefork.c>
StartServers      8
MinSpareServers    5
MaxSpareServers  20
ServerLimit      256
MaxClients      256
MaxRequestsPerChild  4000

<IfModule worker.c>
StartServers        2
MaxClients        150
MinSpareThreads    25
MaxSpareThreads    75
ThreadsPerChild    25
MaxRequestsPerChild  0

Listen 80

LoadModule auth_basic_module modules/
LoadModule auth_digest_module modules/
LoadModule authn_file_module modules/
LoadModule authn_alias_module modules/
LoadModule authn_anon_module modules/
LoadModule authn_dbm_module modules/
LoadModule authn_default_module modules/
LoadModule authz_host_module modules/
LoadModule authz_user_module modules/
LoadModule authz_owner_module modules/
LoadModule authz_groupfile_module modules/
LoadModule authz_dbm_module modules/
LoadModule authz_default_module modules/
LoadModule ldap_module modules/
LoadModule authnz_ldap_module modules/
LoadModule include_module modules/
LoadModule log_config_module modules/
LoadModule logio_module modules/
LoadModule env_module modules/
LoadModule ext_filter_module modules/
LoadModule mime_magic_module modules/
LoadModule expires_module modules/
LoadModule deflate_module modules/
LoadModule headers_module modules/
LoadModule usertrack_module modules/
LoadModule setenvif_module modules/
LoadModule mime_module modules/
LoadModule dav_module modules/
LoadModule status_module modules/
LoadModule autoindex_module modules/
LoadModule info_module modules/
LoadModule dav_fs_module modules/
LoadModule vhost_alias_module modules/
LoadModule negotiation_module modules/
LoadModule dir_module modules/
LoadModule actions_module modules/
LoadModule speling_module modules/
LoadModule userdir_module modules/
LoadModule alias_module modules/
LoadModule rewrite_module modules/
LoadModule proxy_module modules/
LoadModule proxy_balancer_module modules/
LoadModule proxy_ftp_module modules/
LoadModule proxy_http_module modules/
LoadModule proxy_connect_module modules/
LoadModule cache_module modules/
LoadModule suexec_module modules/
LoadModule disk_cache_module modules/
LoadModule file_cache_module modules/
LoadModule mem_cache_module modules/
LoadModule cgi_module modules/
LoadModule version_module modules/
LoadModule ssl_module modules/

Include conf.d/*.conf

User apache
Group apache

ServerAdmin root@localhost

UseCanonicalName Off

DocumentRoot "/var/www/html"

<Directory />
    Options FollowSymLinks
    AllowOverride None
<Directory "/var/www/html">
    Options Indexes FollowSymLinks
    AllowOverride None

<IfModule mod_userdir.c>
    UserDir disable

DirectoryIndex index.html index.html.var
AccessFileName .htaccess
<Files ~ "^\.ht">
    Order allow,deny
    Deny from all
TypesConfig /etc/mime.types

DefaultType text/plain

<IfModule mod_mime_magic.c>
    MIMEMagicFile conf/magic

HostnameLookups Off
ErrorLog logs/error_log
LogLevel warn

LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %b" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

CustomLog logs/access_log combined

ServerSignature On

Alias /icons/ "/var/www/icons/"
<Directory "/var/www/icons">
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all

<IfModule mod_dav_fs.c>
    # Location of the WebDAV lock database.
    DAVLockDB /var/lib/dav/lockdb

ScriptAlias /cgi-bin/ "/var/www/cgi-bin/"

<Directory "/var/www/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all

IndexOptions FancyIndexing VersionSort NameWidth=* HTMLTable

AddIconByEncoding (CMP,/icons/compressed.gif) x-compress x-gzip

AddIconByType (TXT,/icons/text.gif) text/*
AddIconByType (IMG,/icons/image2.gif) image/*
AddIconByType (SND,/icons/sound2.gif) audio/*
AddIconByType (VID,/icons/movie.gif) video/*

AddIcon /icons/binary.gif .bin .exe
AddIcon /icons/binhex.gif .hqx
AddIcon /icons/tar.gif .tar
AddIcon /icons/world2.gif .wrl .wrl.gz .vrml .vrm .iv
AddIcon /icons/compressed.gif .Z .z .tgz .gz .zip
AddIcon /icons/a.gif .ps .ai .eps
AddIcon /icons/layout.gif .html .shtml .htm .pdf
AddIcon /icons/text.gif .txt
AddIcon /icons/c.gif .c
AddIcon /icons/p.gif .pl .py
AddIcon /icons/f.gif .for
AddIcon /icons/dvi.gif .dvi
AddIcon /icons/uuencoded.gif .uu
AddIcon /icons/script.gif .conf .sh .shar .csh .ksh .tcl
AddIcon /icons/tex.gif .tex
AddIcon /icons/bomb.gif core
AddIcon /icons/back.gif ..
AddIcon /icons/hand.right.gif README
AddIcon /icons/folder.gif ^^DIRECTORY^^
AddIcon /icons/blank.gif ^^BLANKICON^^
DefaultIcon /icons/unknown.gif

ReadmeName README.html
HeaderName HEADER.html

IndexIgnore .??* *~ *# HEADER* README* RCS CVS *,v *,t
AddLanguage ca .ca
AddLanguage cs .cz .cs
AddLanguage da .dk
AddLanguage de .de
AddLanguage el .el
AddLanguage en .en
AddLanguage eo .eo
AddLanguage es .es
AddLanguage et .et
AddLanguage fr .fr
AddLanguage he .he
AddLanguage hr .hr
AddLanguage it .it
AddLanguage ja .ja
AddLanguage ko .ko
AddLanguage ltz .ltz
AddLanguage nl .nl
AddLanguage nn .nn
AddLanguage no .no
AddLanguage pl .po
AddLanguage pt .pt
AddLanguage pt-BR .pt-br
AddLanguage ru .ru
AddLanguage sv .sv
AddLanguage zh-CN .zh-cn
AddLanguage zh-TW .zh-tw

LanguagePriority en ca cs da de el eo es et fr he hr it ja ko ltz nl nn no pl pt pt-BR ru sv zh-CN zh-TW

ForceLanguagePriority Prefer Fallback

AddDefaultCharset UTF-8

AddType application/x-compress .Z
AddType application/x-gzip .gz .tgz

AddHandler type-map var

AddType text/html .shtml
AddOutputFilter INCLUDES .shtml

Alias /error/ "/var/www/error/"

<IfModule mod_negotiation.c>
<IfModule mod_include.c>
    <Directory "/var/www/error">
        AllowOverride None
        Options IncludesNoExec
        AddOutputFilter Includes html
        AddHandler type-map var
        Order allow,deny
        Allow from all
        LanguagePriority en es de fr
        ForceLanguagePriority Prefer Fallback


BrowserMatch "Mozilla/2" nokeepalive
BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0
BrowserMatch "RealPlayer 4\.0" force-response-1.0
BrowserMatch "Java/1\.0" force-response-1.0
BrowserMatch "JDK/1\.0" force-response-1.0
BrowserMatch "Microsoft Data Access Internet Publishing Provider" redirect-carefully
BrowserMatch "MS FrontPage" redirect-carefully
BrowserMatch "^WebDrive" redirect-carefully
BrowserMatch "^WebDAVFS/1.[0123]" redirect-carefully
BrowserMatch "^gnome-vfs/1.0" redirect-carefully
BrowserMatch "^XML Spy" redirect-carefully
BrowserMatch "^Dreamweaver-WebDAV-SCM1" redirect-carefully

---------- Post added 08-09-11 at 03:45 PM ----------

oh, btw, shall I mark this as [solved] now? Perhaps the above post belongs elsewhere?

bathory 09-08-2011 02:06 AM


interestingly, my SquirrelMail login page is loading (without SSL) if I visit . At least httpd is now restarting without errors...
As I've told you, you're talking http instead of https in the secure port.
I noticed that you miss the following in ssl.conf:

SSLEngine on
Add it inside the VirtualHost stanza and see if it works


scottmusician 09-14-2011 11:38 PM

Thanks again for the reply - its all working now! seems as though the SSLEngine on did the trick.

Incidentally, I also had to remove the paraphrase from my .key file before my newly downloaded SSL certificate would start to work.

So glad its going - Thanks again!

All times are GMT -5. The time now is 07:33 AM.