LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 09-18-2012, 06:46 PM   #1
tomli21228
LQ Newbie
 
Registered: Sep 2012
Posts: 2

Rep: Reputation: Disabled
Red face install unubtu 12.04 show"unable to install grub in /dev/mapper. my patition


install unubtu 12.04 show"unable to install grub in /dev/mapper' than failed.
my pc is raid 1. patition is:serial ata raid isw_fbcdchiba_Volume0 (mirror) - 500.1 gb linux device. please tall me how to put right decition on this installation step:/dev/mapper
 
Old 09-19-2012, 04:43 PM   #2
mpapet
Member
 
Registered: Nov 2003
Location: Los Angeles
Distribution: debian
Posts: 547

Rep: Reputation: 72
GRUB's root device is not /dev/mapper. I think /dev/mapper is a device node for an LVM disk??? In this instance, you need to install GRUB to the hard disk device node that is in /dev/mapper. You probably don't have a real hardware RAID either. There should be some devices like /dev/sda, /dev/sdb present. The right thing to do is to install GRUB to both hard disks in the logical disk.

Ubuntu's installer is very weak for fancier installations. IMHO, switch to Debian because their installer does fancier disk configurations better.

Last edited by mpapet; 09-19-2012 at 04:52 PM.
 
Old 09-20-2012, 01:45 PM   #3
tomli21228
LQ Newbie
 
Registered: Sep 2012
Posts: 2

Original Poster
Rep: Reputation: Disabled
Smile got the result, thanks

mpapet, thank you very much for help and let me know some more things
I find out the result . just follow the dev/mapper/ put patition name , it will work
Have a wonderful day!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL 6.0 + OnBoard HW RAID + GRUB to MBR /dev/mapper/pdc_blah kurasoe Red Hat 5 07-13-2011 04:46 PM
grub-install - old install has lost /dev/hdxx Peit Linux - Software 3 08-28-2006 09:28 AM
Solved -- grub-install "/dev/hdx does not have any corresponding BIOS drive" error jlinkels Linux - Software 2 01-10-2006 08:33 AM
Will "grub-install /dev/hda" kill Windows XP MBR? Zullocrit Linux - Newbie 3 09-25-2004 09:50 AM
"unable to find device node for /dev/x in /dev!" during install zombiedeth *BSD 0 02-02-2004 02:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 05:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration