-   Linux - Server (
-   -   IBM server 226 + Ubuntu server (raid) (

way3000 11-12-2013 01:30 PM

IBM server 226 + Ubuntu server (raid)
Hello AL.

I am trying to install ubuntu on my server but keep ending in a partition problem.

here are som details

Server: IBM 226 - 8488 with 3 73 GB disks in raid SCSI Xeon 3.0 and 3GB RAM
Software: Ubuntu server 12.04 (so uses Grub2)

Problem: In both Raid 1 and Raid 0 (Cannot do raid 5 for some reason) I end up at the installation part where I have to write the partition information to disk. It keeps saying it cannot write the ext4 partition.

I tried using a guide on how to manual partition, I make a partition of 6GB to swap and rest for ext4 part. But I specify these as physical volume for RAID where the 67GB part as bootflag: on

then I go to create a MD device in the setup RAID part of the partitioner. It dosen't write this info, I can pick it but it dosen't save the info so when i ask to write the information it keeps telling me there is no root specified.

What can I do now? (see image below / link)

Pearlseattle 11-12-2013 03:30 PM


I lack the knowledge of your particular HW, so I cannot give help you directly :(
In any case, here are some sources of "inspiration":

You might want to push for the raid5 - could potentially be faster than a raid1 (saying this because in my case the the sw-raid5 was as fast as the sw-raid0-config I tested and definitely faster than the sw-raid1 I tested as it kept reading only from single a single HDD).

Just for general information, what are the details about the "root" and the (potentially separate) "boot" partitions?
Obviously if you're using sw-raid and are putting the boot partition (or maybe the root partition which includes the boot files) onto the sw-raid the system will never boot => did you create a boot partition on the two/three separate drives so that the PC's BIOS will (hopefully) automatically try to access the next drive if the previous one is broken? Or maybe you aren't using those drives at all to boot?
And how will it work later? Will the sw-raid module compiled in the kernel automatically check the HDDs and auto-assemble them before taht the root-partition is mounted (if you're putting the root partition on the sw-raid)?

You could try to install first some other distributions - e.g. Fedora, CentOS, anything -, let them do the dirty job of partitioning & formatting the HDDs and then once the installation of any of those distributions worked and boots with the setup you want to have just install Ubuntu selecting to replace the existing OS.
Saying this because this is the way I did it when I installed Ubuntu a few months back using a particular setup - Ubuntu just kept complaining about partitions or just did not boot after having installed it, the messages during its installation did not show enough details and I ended up installing it as I just mentioned above.

Hope this helps

way3000 11-12-2013 05:47 PM


Thank you for input! (I really need some hehe)

ok, first, I cannot set a raid 5, for some reason the ServerGuide to my server only allows 0, 1 and 10. Bummer.

About the partitioning:
I tried two different setups, none worked.

1: 6 GB swap and 67GB ext4 root partition (with bootflag:on)
2: 6 GB swap and 67GB ext4 both set to physical volume for RAID (as specified in this guide: )

Setup #1 procudes the "cannot write ext4 partition error"
Setup #2 procudes the "no root set error" the 67GB partition set with Bootflag:on (as none are specified)

I am kinda new to raids (or haven't worked in computers for 7ish years so kinda lost touch) the server seems to run a hardware raid, so I am unsure if the option to "create MD device" is just creating a software raid on a hardware raid (and causing troubles)

All I have tried has been tried both on raid 0 (Striping) and raid 1 (mirroring) and raid 1 + 1 hot spare, all unsuccesfull.

I am unsure what you mean by creating a boot partition on seperate drives, as the installer only sees one drive (either a 73 GB * 3 striped drive as 1 drive, or a 73 GB drive which is mirrored)

I was hoping that, when the installer had GRUB2 installed, the bios would understand that it should boot on what grub tells it to?

I don't know how to make a seperate drive for booting up on and maybe from there have files and stuff (webserver mostly) run off the striped or mirrored disks?

Really thought the HW raid 0 would just act as a normal harddrive so the normal installation just run through and voilá.

The idea with some other distro is not bad, I might try that, but I am quite stubborn, so I really would love to get the ubuntu installer to work so I knew what caused the problem.

Pearlseattle 11-12-2013 06:07 PM

Hi way3000


...I really would love to get the ubuntu installer to work so I knew what caused the problem.
windows_7 way3000 is online now Add to way3000's Reputation Report This Post
Unluckily the ubuntu intaller does not output too often useful informations.

I really donn't understand why this happens:

Setup #1 procudes the "cannot write ext4 partition error"
Writing should be no problem, even if if all informations are invalid.
Maybe you have some kind of weird HW-raid that prevents some writes? But if that would be the case then even creating the partitions would fail.
I am currently clueless.

I am a Gentoo user and I usually don't make publicity for any problem posted here, but maybe you should try out its first steps ( - up to "Preparing the disks") to at least see exactly where the whole thing fails?


way3000 11-12-2013 06:32 PM

I am clueless aswell, and yea it might have something to do with the hardware raid (damned crap!)

I will try a gentoo handbook try and see if that helps with more usefull information, great idea. Currently downloaded the CentOS to see if that has anything to say, will try gentoo next if that dosen't work out right.

I might suspect the ServerGuide to have something to do with it in some way, but I can't put a finger on what it could be. (I guess it might have a problem with a driver loaded maybe?)

way3000 11-12-2013 07:16 PM

Might have found a tiny clue: Ubuntu server apparently stinks at hardware raid, so that mean I am in dire need of learning how to use gentoo or suse og CentOS. Not that they are bad, I just only have experience in ubuntu :( so that puts me way back.

way3000 11-12-2013 08:39 PM


I have cleared the problem and it works now, sad thing is, I don't have an exact solution.

What I did: Gave up on ubuntu server 12.04 - downloaded the Gentoo distro and fired that up, tried to install this new distro from liveCD and ended up messing up in Fdisk (not sure what I ended ud doing but not sure this is relevant as I think the CD allready has done what needs to be done here)

So, after giving up on Gentoo, I found this link, you don't need to read it untill you read the last of this post:
Now, after reading this blog, which you don't cause I didn't end up using this. I fired up the Ubuntu server CD again and this time, the partitioner could see 3 seperate disks (those disks on the RAID controller)

How I don't know, but it could, and also the messed up partitions I managed to make with Gentoo/Fdisk.

From here I could delete the mistakes I made, create a MD device, pick Raid 0 and just continue the installation as normal. (I made 1 HD /dev/sda to be the one with the boot partition and the 2 disks striped in a raid 0 so that I have one "disk" for ubuntu and one (combined) "disk" for files and such.

This ended up in a easy to manage install that took less than 20 mins to complete inclusive a game or two of candy crush.

I hope this helps others in the same situation as I.

Thanks for the help and support! :)

Ubuntu on Hardware Raid 0 (guess 1 or 5/10 would work too) is now a reality! (through Gentoo liveCD/Fdisk)

Pearlseattle 11-14-2013 01:05 PM

So, the solution would be to mess up the HDDs with Gentoo so that Ubuntu is able to recognize them?

way3000 11-15-2013 05:02 AM

And fix what you just messed up yeah :P I assume gentoo puts something in the HW raid that makes it recogniseable for ubuntu to partition on.

All times are GMT -5. The time now is 11:52 AM.