LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 06-18-2010, 02:30 PM   #1
nithinsha
LQ Newbie
 
Registered: Jun 2010
Posts: 4

Rep: Reputation: 0
HTTPD NOT Starting


Just now I had configured server

vhosts added

but when I start it i am getting

[root@cloud /]# /etc/rc.d/init.d/httpd start
Starting httpd: [Fri Jun 18 18:25:24 2010] [error] (EAI 3)Temporary failure in name resolution: Could not resolve host name yourhostname -- ignoring!
Warning: DocumentRoot [/www/your-domain/html] does not exist


Can anyone help me
 
Old 06-18-2010, 02:55 PM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
Really, as it says.

yourhostname is not resolvable. fix it in DNS or add it to /etc/hosts.
/www/your-domain/html does not exist. create it.
 
Old 06-18-2010, 03:18 PM   #3
nithinsha
LQ Newbie
 
Registered: Jun 2010
Posts: 4

Original Poster
Rep: Reputation: 0
How to add it sir

can you please tell me steps
 
Old 06-18-2010, 10:56 PM   #4
edenCC
Member
 
Registered: May 2006
Location: Gz,China
Distribution: RH,FB
Posts: 198
Blog Entries: 1

Rep: Reputation: 32
Hi, nithinsha,
As it says - -- ignoring!, you can simply ignore this issue.
I suspect there might be some issues on the vhost configuration. It's the point why httpd cannot start.

what does error_log say? By default this file stored in /var/log/httpd/error_log*
 
Old 06-19-2010, 01:34 AM   #5
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
nithinsha -

1. AlucardZero is absolutely correct. You need to:
a) make sure the "DocumentRoot" you specified actually exists (and has correct permissions) on your filesystem

b) if you're using vhosts, make sure the DNS name of your virtual host is actually defined in DNS

2. There are many, many tutorials, FAQs and howto's available that describe how to do both of these things.

There *are* no simple "1,2,3", rote, cookbook instructions anybody can give you.

'Hope that helps .. PSM
 
Old 06-19-2010, 04:53 AM   #6
nithinsha
LQ Newbie
 
Registered: Jun 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Sir,

Its rackspace cloud server

my host address is cloud.invign.net

can you could give me some tutorial links ..i kad check vhosts...DNS Name is right
 
Old 06-19-2010, 03:19 PM   #7
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
1. make sure the "DocumentRoot" you specified actually exists (and has correct permissions) on your filesystem
The error says that it doesn't, you haven't shown any attempt to verify that it does.

2. Make sure that the *DNS Name you specified in your VHost section* actually exists. If your vhost is for "moose", then try to ping "moose". If your "vhost" is for "moose.cloud.invign.net", then make sure you can ping "moose.cloud.invign.net", "cloud.invign.net" and "moose".

3. Try this diagnostic:
Apache -S command l

4. Look in "/var/log/httpd/error_log". You were asked to do this, and you haven't shown any attempt to try.

5. Consider if you really need a "vhost" in the first place? Maybe all you need is a simple configuration!

'Hope that helps .. PSM
 
Old 06-19-2010, 05:00 PM   #8
nithinsha
LQ Newbie
 
Registered: Jun 2010
Posts: 4

Original Poster
Rep: Reputation: 0
now i am not getting other errors

just httpd [Failed]

below is what i got from error_log


--------------------------------------------------------------------------[Sat Jun 19 18:16:51 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Sat Jun 19 18:16:51 2010] [notice] Digest: generating secret for digest authentication ...
[Sat Jun 19 18:16:51 2010] [notice] Digest: done
[Sat Jun 19 18:16:51 2010] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations
[Sat Jun 19 20:29:14 2010] [notice] caught SIGTERM, shutting down
(21)Is a directory: httpd: could not open error log file /www/invign.com/logs/error_log.
Unable to open logs
(21)Is a directory: httpd: could not open error log file /www/invign.com/logs/error_log.
Unable to open logs
(21)Is a directory: httpd: could not open error log file /www/invign.com/logs/error_log.
Unable to open logs
(21)Is a directory: httpd: could not open error log file /www/invign.com/logs/error_log.
Unable to open logs
(21)Is a directory: httpd: could not open error log file /www/invign.com/logs/error_log.
Unable to open logs
(21)Is a directory: httpd: could not open error log file /www/invign.com/logs/error_log.
Unable to open logs
(21)Is a directory: httpd: could not open error log file /www/invign.com/logs/error_log.
Unable to open logs
------------------------------------------------------------------------

changed host to m.invign.com
 
Old 06-20-2010, 01:03 AM   #9
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
OK - you've successfully fubar'ed your Apache configuration.

Do this:
1. Take a backup of any custom web content you've created (a simple "tar" file should be fine)

2. DE-INSTALL Apache ("yum remove" your Apache package)

3. Re-INSTALL Apache ("yum install" your Apache package: get a CLEAN INSTALL)

4. Verify that Apache works

5. Add your WEB CONTENT. Verify that it works.

6. STOP if everything's OK. DON'T make any other changes unless you NEED to, and unless you KNOW WHAT YOU'RE DOING.
 
Old 06-20-2010, 01:46 AM   #10
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,400

Rep: Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584
and you might want to reread the apache docs page
http://httpd.apache.org/docs/2.2/

I tell people to study them " as if you ARE going to take a final exam on this"
because YOU ARE -- the web site .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting httpd: /etc/init.d/httpd: line 40: 10243 Segmentation fault LANG=C grep RMLinux Linux - Newbie 10 12-01-2008 11:17 PM
Starting httpd: httpd: Syntax error on line 209 of /etc/httpd/conf/httpd.conf: Syntax sethukpathi Linux - Networking 6 04-12-2008 12:26 PM
Failed to start apache :Starting httpd: Syntax error on line 1027 of /etc/httpd/conf/ payjoe Linux - Newbie 3 09-21-2007 08:24 AM
Starting httpd: /usr/sbin/httpd: symbol lookup error: /usr/local/lib/libaprutil-0.so. bijuhpd Linux - Newbie 1 10-30-2005 06:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 07:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration