LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 04-01-2007, 02:56 AM   #1
SgtM
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Rep: Reputation: 0
httpd - Fedora Core 6


Hey all. Another Linux noob here. So, I installed Fedora 6 tonight, and I want to set it up as a web server for my home. Why? Learning experience. I followed a guide on howtoforge.com about installing a LAMP with Fedora 6, but httpd will not start no matter what I try. I tried looking in /var/log/httpd, but the directory is empty. When I try and start apache, I get the following output:

root@localhost ~]# /etc/init.d/httpd start
Starting httpd: [FAILED]

Any suggestions?
 
Old 04-01-2007, 07:05 PM   #2
hollywoodb
Member
 
Registered: Aug 2003
Location: Minnesota, U.S.A.
Distribution: Debian, openSUSE
Posts: 400

Rep: Reputation: 30
try using
Code:
apachectl start
which is apache's actual start/stop/restart tool. It might give you more information as to why it doesn't start. Once you get it working then you should be able to use Fedora's httpd service like you are attempting to do now.
 
Old 04-01-2007, 07:43 PM   #3
SgtM
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks hollywood. I'll try that when I get home tomorrow morning.
 
Old 04-04-2007, 10:21 AM   #4
SgtM
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Well, I really screwed things up somehow. No biggie. This box is just so I can play around with a linux web server. So, I reinstalled FC6 last night, and Apache is running without issue.

Thanks again hollywood!
 
Old 04-04-2007, 11:08 PM   #5
sirclown82
LQ Newbie
 
Registered: Feb 2005
Location: Bedford, Texas
Distribution: Fedora, CentOS
Posts: 11

Rep: Reputation: 0
Question httpd.conf syntax error?

Maybe i can tag on to this thread. I just installed apache 2.2+ on FC6, and httpd will not start because, on startup, it says that /etc/httpd/conf/httpd.conf has an syntax error on line 170. I am fairly new to Linux in general, and i dont understand syntax. Here is what it says on line 170 -
LoadModule access_module modules/mod_access.so

This is something that was written in the file when i did the install. whats the problem in there? I don't see anything, but thats my inexperienced eye looking at it too.

Thanks,
Chris

Last edited by sirclown82; 04-04-2007 at 11:24 PM.
 
Old 04-09-2007, 08:01 AM   #6
hollywoodb
Member
 
Registered: Aug 2003
Location: Minnesota, U.S.A.
Distribution: Debian, openSUSE
Posts: 400

Rep: Reputation: 30
Quote:
Originally Posted by sirclown82
Maybe i can tag on to this thread. I just installed apache 2.2+ on FC6, and httpd will not start because, on startup, it says that /etc/httpd/conf/httpd.conf has an syntax error on line 170. I am fairly new to Linux in general, and i dont understand syntax. Here is what it says on line 170 -
LoadModule access_module modules/mod_access.so
I don't see a problem with that at all... what do the lines immediately before and after that line look like?

BTW, you'll likely get a better response if you just start a new thread
 
Old 04-09-2007, 10:49 AM   #7
sirclown82
LQ Newbie
 
Registered: Feb 2005
Location: Bedford, Texas
Distribution: Fedora, CentOS
Posts: 11

Rep: Reputation: 0
Thumbs up

I went ahead and uninstalled the entire web server packages in the package manager and started from scratch, this time not using the HTTP configuration GUI, and it now is working. I dont think that i had all the modules installed the first time. Thanks for the response.

Chris

Last edited by sirclown82; 04-09-2007 at 10:50 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora core 6 httpd and php Net_Spy Linux - Server 1 03-27-2007 03:06 PM
Apache httpd start failed on fedora core 1 k_1701 Linux - Software 10 05-05-2006 07:40 AM
PHP5 & HTTPD (apache) on Fedora Core 4 fatum112 Linux - Software 4 12-02-2005 05:44 PM
Fedora Core 4 and, (apparently), HTTPD... Galaxy_Stranger Linux - Newbie 15 11-10-2005 01:23 PM
Fedora Core 4 goes offline, no httpd or sshd access FC3_User Linux - General 2 10-19-2005 05:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 06:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration