LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 06-14-2010, 01:35 AM   #1
er.surendersharma
Member
 
Registered: May 2010
Posts: 47
Blog Entries: 2

Rep: Reputation: 15
How to run graphical application on the rock cluster node


Dear Friends

I am trying to rock cluster for the large computing. my all slave node connected with rock cluster master node. but I want to run the graphical application on the cluster node. I am not getting this point .

Please help me in this problem...



thanks.
surender sharma
 
Old 06-14-2010, 10:11 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,701

Rep: Reputation: 6939Reputation: 6939Reputation: 6939Reputation: 6939Reputation: 6939Reputation: 6939Reputation: 6939Reputation: 6939Reputation: 6939Reputation: 6939Reputation: 6939
Quote:
Originally Posted by er.surendersharma View Post
Dear Friends

I am trying to rock cluster for the large computing. my all slave node connected with rock cluster master node. but I want to run the graphical application on the cluster node. I am not getting this point .
Maybe we could, if you actually told us what the problem was, and what you're doing. Saying "I am not getting this point" gives us nothing to go on. What application? What error(s) are you getting? What have you tried????
 
Old 06-15-2010, 05:36 AM   #3
er.surendersharma
Member
 
Registered: May 2010
Posts: 47

Original Poster
Blog Entries: 2

Rep: Reputation: 15
Run the Graphical Application

Quote:
Originally Posted by TB0ne View Post
Maybe we could, if you actually told us what the problem was, and what you're doing. Saying "I am not getting this point" gives us nothing to go on. What application? What error(s) are you getting? What have you tried????
Hello

Actually, I am trying to rocks cluster . I am running the master node with the SGE and client node is connected to the master node.
we can run the batch jobs to the client node easily commands.

PROBLEM::
but I want to run Interactive or graphical application on the client node from the master node.

There is cmd qsh for the Display of client node like xterm.
but it is giving error
error: no Display Variable defined.
How can I run a graphical application on the client nodes thru the master node.

if u have tried or u have knowledge about htis thing then reply me.
please give me the solution immediately

Thanks
Surender Sharma
 
Old 06-15-2010, 05:43 AM   #4
er.surendersharma
Member
 
Registered: May 2010
Posts: 47

Original Poster
Blog Entries: 2

Rep: Reputation: 15
Run the Graphical Application

Quote:
Originally Posted by TB0ne View Post
Maybe we could, if you actually told us what the problem was, and what you're doing. Saying "I am not getting this point" gives us nothing to go on. What application? What error(s) are you getting? What have you tried????
Actually, My application is (CLCworkbench) Bio Calculation software.
I want that I run this application on the master node and my SGE sechduler will sechdule this application to my nodes. but my nodes are not graphical booted. these are installed from the "PXE BOOT".
Now How Can I run a graphical application or interactive jobs on these nodes.

Tell me any solution .

Thanks.
surender sharma
 
Old 06-15-2010, 10:21 AM   #5
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,701

Rep: Reputation: 6939Reputation: 6939Reputation: 6939Reputation: 6939Reputation: 6939Reputation: 6939Reputation: 6939Reputation: 6939Reputation: 6939Reputation: 6939Reputation: 6939
Quote:
Originally Posted by er.surendersharma View Post
Hello

Actually, I am trying to rocks cluster . I am running the master node with the SGE and client node is connected to the master node.
we can run the batch jobs to the client node easily commands.

PROBLEM::
but I want to run Interactive or graphical application on the client node from the master node.

There is cmd qsh for the Display of client node like xterm.
but it is giving error
error: no Display Variable defined.
How can I run a graphical application on the client nodes thru the master node.

if u have tried or u have knowledge about htis thing then reply me.
please give me the solution immediately
Spell out your words, and don't tell us to hurry up and answer you. We volunteer our time here to answer questions, so telling us to hurry up is very rude.

If you need "immediate" answer, then try Google, or pay for support. If you tried to look up the error you got
Quote:
no Display variable defined
you'd see what the problem is, and how to solve it. As it clearly says, you need to define a display variable. So, before running your application, set the DISPLAY variable, like "export DISPLAY=<IP address of X enabled worsktation>:0", then run it.
 
Old 06-16-2010, 12:38 AM   #6
er.surendersharma
Member
 
Registered: May 2010
Posts: 47

Original Poster
Blog Entries: 2

Rep: Reputation: 15
Quote:
Originally Posted by TB0ne View Post
Spell out your words, and don't tell us to hurry up and answer you. We volunteer our time here to answer questions, so telling us to hurry up is very rude.

If you need "immediate" answer, then try Google, or pay for support. If you tried to look up the error you got

you'd see what the problem is, and how to solve it. As it clearly says, you need to define a display variable. So, before running your application, set the DISPLAY variable, like "export DISPLAY=<IP address of X enabled worsktation>:0", then run it.



Thanks for replying.
I have tried the DISPLAY=<IP address of X enabled worsktation>:0",
Question ->>we have to export this DISPLAY variable from client node or master node.
What I have tried ?
I exported the DISPLAY variable from client node.

now I want to take the xterm display of that node at the master cluster node so that I cud run the graphical application. but it is not showing the display of that client node...

Is there any configuration to catch that DISPLAY variable at the master node

I have tried the ( qsh ) at master node . but it is not working . Is there any option of this problem besides of qsh . then help me.

and I really appericiate of you for replying .
you know near abt. 90 person have seen this blog but nobody din give answer of this problem.

you are the only person who has given the solution of this problem . and I also saw that you are the GURU of linuxquestions.org .its pleasure of mine that aperfect person has given me solution to me.

thanks
surender sharma
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mysqld node of mysql cluster system not connecting to management node coal-fire-ice Linux - Server 1 07-27-2015 08:33 AM
How to add application to Rock Cluster kumar.manoj412 Linux - Server 0 06-07-2010 09:15 AM
[SOLVED] Is Red Hat Cluster suitable for balancing the node of multiple application servers? XXLRay Linux - Enterprise 2 06-03-2010 06:56 AM
[SOLVED] Rocks Cluster node asking for rolls upon node install Shouraku ROCK 1 04-15-2010 10:28 AM
How to enable root to run graphical application in user log in xgreen Slackware 4 03-07-2005 06:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 10:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration