-   Linux - Server (
-   -   Help! Unable to boot new kernel (

pafoo 10-10-2012 03:09 PM

Help! Unable to boot new kernel
I am running RHEL 6.1 on a physical server. I updated recently to 6.3. When booting to the new kernel I get kernel panic - not syncing: No init found.

I have since reinstalled the kernel, installed 3 different versions of the kernel all give the same error. The entire time I am able to boot in to the 6.1 kernel with NO problems at all. I have filesystem checked every drive and checked the grub config against a working server that was patched.

Please help!

Bazzaah 10-10-2012 03:16 PM

You need to create an init (initial RAM disk) - your error message says 'no init found'. The absence of an init will cause a kernel panic in (some) Slackware kernels too.

You'll need to find out how to do that on RHEL.

pafoo 10-10-2012 03:52 PM

I checked and the initramfs does exsist for the kernel.

silendo 10-10-2012 03:59 PM

Or you must recompile kernel without initrd support, so you dont have a problem with initrd image

Reuti 10-11-2012 06:23 AM

How did you install the new kernel? There is the script mkinitrd on openSUSE to create an initrd for the particular kernel/mainboard combination. AFAICS there is a similar one for RHEL.

pafoo 10-11-2012 09:27 AM

I installed the RPM using both YUM and I tried with RPM.

lnxsravan 01-23-2014 02:03 AM

boot the system in rescue mode
bash#chroot /mnt/sysimage (used to check the filesystems appear as if they are mounted under / directly)
shell#mkinitrd -f /boot/initramfs................(for rhel5)
#dracut -f /boot/initramfs.................(for rhel6)

All times are GMT -5. The time now is 05:32 AM.