-   Linux - Server (
-   -   freenx (remote control) display problem, unclean shutdown (

speedsrfr 10-05-2009 05:44 AM

freenx (remote control) display problem, unclean shutdown
I started using the gpl version of nomachine nx remote control software because of its good support for my international keyboard unlike vnc, and because of the speed.

Unfortunately every time I turn off the remote pc with the powerbutton and forget to close off my nx session i was running from my laptop, it records this, and even if I run

nxserver --cleanup

nxserver --history -clear
the next time i boot the computer, the connection I make from my laptop is on a new display. For example I connected on display 1000 (normal base display for nx) then I had an unclean shutdown and the next time i connected it made me use 1001. Ive had a few more mishaps and Im at 1005 now. Is there any way to clean this up. I tried

nxserver --uninstall --purge
and reinstalling the rpms but it doesnt work.
Please help. Thank you.

kbp 10-06-2009 09:03 AM


I think the dead sessions are probably being tracked on your laptop, try looking in ~/.nx


speedsrfr 10-07-2009 03:19 AM


Originally Posted by kbp (Post 3709511)

I think the dead sessions are probably being tracked on your laptop, try looking in ~/.nx


I uninstalled nx on the laptop and reinstalled it and made sure .nx was deleted so it would have to create a new one.
I get a lot of these errors on connection i usually just restart the nxserver and then it users a new display. I then connected again and made sure nx owned the var/lib/nxserver directory, the eroor dissapeared but it didnt help it still used display 1005 instead of 1000. *sigh* do I really have to reinstall my entire system? surely not. I use a windows client from nomachine if that makes a difference

NX> 203 NXSSH running with pid: 3792
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 2.1.0-72 OS (GPL, using backend: 3.2.0)
NX> 105 hello NXCLIENT - Version 2.1.0
NX> 134 Accepted protocol: 2.1.0
NX> 105 login
NX> 101 User: roland
NX> 102 Password:
NX> 103 Welcome to: susefilesrv user: roland
NX> 105 listsession --user="roland" --status="suspended,running" --geometry="1280x1024x32+render" --type="unix-kde"
NX> 127 Sessions list of user 'roland' for reconnect:

Display Type            Session ID                      Options  Depth Screen        Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------

NX> 148 Server capacity: not reached for user: roland
NX> 105 startsession  --link="adsl" --backingstore="1" --encryption="1" --cache="16M" --images="64M" --shmem="1" --shpix="1" --strict="0" --composite="1" --media="0" --session="testing" --type="unix-kde" --geometry="1024x768" --client="winnt" --keyboard="pc102/ch" --screeninfo="1024x768x32+render"

NX> 1000 NXNODE - Version 2.1.0-72 OS (GPL, using backend: 3.2.0)
NX> 700 Session id: susefilesrv-1005-15BF4F4CCBD38F2D9722B5EE24C46888
NX> 705 Session display: 1005
NX> 703 Session type: unix-kde
NX> 701 Proxy cookie: 29ac033b9fb85725367ef331a3c34a36
NX> 702 Proxy IP:
NX> 706 Agent cookie: 29ac033b9fb85725367ef331a3c34a36
NX> 704 Session cache: unix-kde
NX> 707 SSL tunneling: 1
NX> 105 NX> 596 Session startup failed.
NX> 1004 Error: NX Agent exited with exit status 1. To troubleshoot set SESSION_LOG_CLEAN=0 in node.conf and investigate "/home/roland/.nx/F-C-susefilesrv-1005-15BF4F4CCBD38F2D9722B5EE24C46888/session". You might also want to try: ssh -X myserver; /usr/bin/nxnode --agent to test the basic functionality. Session log follows:
/usr/bin/nxserver: line 1371: 12775 Terminated              sleep $AGENT_STARTUP_TIMEOUT
Can't open /var/lib/nxserver/db/running/sessionId{15BF4F4CCBD38F2D9722B5EE24C46888}: No such file or directory.
NX> 1006 Session status: closed
mv: cannot stat `/var/lib/nxserver/db/running/sessionId{15BF4F4CCBD38F2D9722B5EE24C46888}': No such file or directory
NX> 1001 Bye.
NX> 280 Exiting on signal: 15

kbp 10-07-2009 05:46 PM

It doubt it would make a difference whether you are running on Windows, have you tried verifying the package install? ('rpm -V nxserver?')
.. does it really matter if the display number keeps incrementing ?

speedsrfr 10-10-2009 04:23 AM

i tried but rpm -v gives verbose says the rpm help, not verify.
Maybe it doesnt matter. and I should just give it up as a bad job. Im open to any other ideas. but thanks very much for your help so far.

kbp 10-10-2009 09:27 AM

That's a capital 'V' not a lowercase one

v = version
V = verify


All times are GMT -5. The time now is 01:15 AM.