-   Linux - Server (
-   -   FQDN for home server (

charlie0313 06-12-2008 05:55 PM

FQDN for home server
I really want to have my own FQDN for my apache web server. I've been looking around and can't find out how to do this. Do I need to go through my ISP or is there a company somewhere that will give me a FQDN for my server at home? Any suggestions or sources for information would be great.


billymayday 06-12-2008 06:01 PM

Do you mean to access from outside of home? Any domain registry can sell you a domain name If you do this, you'll need to find a nameserver (like, but first, check if you have static or dynamic IP, and if your ISP allows you to run a web server (ie they don't block port 80)

If you only want to access it internally, make one up (that won't conflict with public names), so something like domain.home would work

dguitar 06-12-2008 06:41 PM

I think this is what you might be looking for:

checkmate3001 08-03-2008 06:19 PM

Sorry if I hi-jacked this thread... but it was so related I didn't want to start a whole other thread...

I've used It works well for serving websites. I wonder, however, can you also make a mail server than you can actually send e-mail with. I have successfully gotten my server to accept e-mail (so much junk-mail tho) but I have been unable to send e-mail successfully. I assume this is something I would have to talk to my ISP about?

I believe it has something to do with my fqdn and IP not resolving to each other.
If I do a:

dig -x < my IP addy >

; <<>> DiG 9.3.4-P1.1 <<>> -x < my IP addy >
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 35414
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;< addy my IP >    IN      PTR

< addy my IP > 86400 IN    PTR    c-< my IP addy >

;; Query time: 60 msec
;; WHEN: Sun Aug  3 15:55:22 2008
;; MSG SIZE  rcvd: 93

It resolves to a hostname my ISP owns, not my fqdn.

billymayday 08-03-2008 06:22 PM

You'll probably have all sorts of problems with servers at the other end rejecting you as spam. Why don't you relay outgoing mail through your ISPs smtp server?

What MTA are you running (sendmail/postfix/whatever)?

checkmate3001 08-03-2008 06:38 PM

Thanks for the advice. I just found this post:

I'm using postfix so I will adapt the information I found in this for postfix. I didn't really understand how a smarthost worked until I read that post. Looks very promising.

Mr. C. 08-03-2008 07:06 PM

checkmate30001, along with what billymayday mentioned about remote MTAs rejecting email from your dynamic IP, your ISP may very well block outbound port 25, preventing you from operating a mail server directly. Your only option here would be to establish a smarthost setup where your relay to your ISPs mail server.

checkmate3001 08-03-2008 07:48 PM

I would assume that your just make the reply-to address in the mail the address to your e-mail server and not your smarthost e-mail address?

Mr. C. 08-03-2008 07:53 PM

A Reply-To header is simply for your own use, to have others attempt a reply where you'd like. You set this in your MUA. This has no affect on bounce processing, nor do mail servers generally consider it as a reliable header for anti-spam control.

Your ISP will either accept or reject the message. If it is accepted for delivery, but cannot be delivered, the mail will be bounced back to the Envelope Sender. This is the address you need to configure correctly.

checkmate3001 08-03-2008 08:11 PM

Mr. C - Thank you for the info. Very helpful.

charlie0313 - Did you ever get your web server to work? We can offer pointers if you need help.

All times are GMT -5. The time now is 04:52 AM.