-   Linux - Server (
-   -   Fedora 10 won't boot off a Raid 1 /dev/md0 setup?? (

jg167 05-27-2009 09:10 PM

Fedora 10 won't boot off a Raid 1 /dev/md0 setup??
I installed Fedora 10 on a config that has /boot and / on md mirrors. I did this with Centos 5.3 and it worked fine (or at least it booted without any problems). I have instaled Fedora 9 with / (no separeate /boot) on a RAID 1 md setup and it also worked. But now after booting the newly installed fedora 10 it just drops me into grub> . I booted rescue mode off the dvd and pooked around and don't see a problem, but don't know what ending up in grub> reallly imples so am not sure what to look for (my md setup is all there, the fs's are fine etc). Comparing things to another system all the /boot/grub/* files are present etc. I had the install do the grub install so the MBR etc should have been written. Suggestions?

jg167 05-28-2009 03:15 PM

The RAID HowTo has this covered. The section on booting

grub>device (hd0) /dev/hdc
grub>root (hd0,0)
grub>setup (hd0)

For me I did this for /dev/sda and /dev/sde, the two drives in my /boot volume, and that did the trick. I did this from rescue mode after booting the install DVD, but a live CD would work just as well.

All times are GMT -5. The time now is 06:41 PM.