-   Linux - Server (
-   -   Error 506 during Funambol sync with Citadel groupware server (

penyuan 06-18-2011 06:01 PM

Error 506 during Funambol sync with Citadel groupware server

I am running an installation of Scientific Linux 6.0 (it is literally RHEL 6 minus the brand), and have successfully setup Citadel Groupware, and synced it with a Mozilla Thunderbird client with the Lightning calendar extension. It is very nice!

However, for the Citadel server to sync with my iPhone, I need to, and have have downloaded and successfully started the latest Groupware Sync Server from here. The Groupware Sync Server is basically an installation of Funambol, specially made to work with Citadel.

I tried to connect to the server from my iPhone with the Funambol connector app, and the Synthesis SyncML app, but none of them worked when I pointed them to: http://[hostname]:8080/funambol/ds (which is what the Groupware Sync Server documentation told me). Of course, I replaced [hostname] with my actual hostname.

I checked the logs of both sync apps, and they both say the following:


[ERROR] processItemStatus: server sent status 506 in SYNC
[ERROR] Error #506 in source addressbook
On the Citadel and Groupware Sync Server forums, I was told that error 506 meant its something on the server going on, so I got the two relevant log files, /opt/Funambol/logs/ds-server/ds-server.log, and /opt/tools/tomcat/logs/catalina.out (the links point to pastebins of the output).

What does "error 506" mean, and how do I correct it?

BTW, I disabled my entire firewall just in case that was the issue.

I would appreciate any specific instructions/help you can give me, as I am really eager to set this up. Thank you in advance for your help.

penyuan 06-28-2011 02:40 PM


All times are GMT -5. The time now is 10:18 PM.