-   Linux - Server (
-   -   Edubuntu 11.10 LTSP installation shuts off other network to internet (

eccampbell 03-19-2012 07:33 PM

Edubuntu 11.10 LTSP installation shuts off other network to internet
I have two network connectors, one on the mainboard and the other in a PCI slot, and have tried LTSP several times both from a live-CD session (actually Edubuntu 11.10 comes on a DVD) and by installing to disk. Both network connections work fine for connecting to the intenet, but as soon as LTSP is tested from the live-CD session the internet shuts off and nm-tool reports that connection -- whether it is eth0 or eth1 -- as unavailable or unmanaged. Same if I install Edubuntu to the hard disk and select LTSP Server as an installation option.

I wonder if this could be related to the computer, Dell Optiplex 755, because using the same PCI card on an older computer I did have LTSP from Edubuntu 8.04 up and running OK.

I have tried switching cables each way and reinstalling, switching cables after installing, every possibility, and the behavior is the same.

For example, if I install LTSP (or test LTSP via live-CD session) with the internet cable on the mainboard connector (eth0) and the gigabit router on the NIC card (eth1), then eth0 does not work, registering a state of unmanaged or unavailable with nm-tool. The internet is cut off. But I can get the internet back by switching the internet cable to eth1, and then nm-tool reports eth1 as connected and eth0 as unmanaged. The same phenomenon occurs in reverse with the two network connectors. I do not want internet and the thin-client network to be on the same network and don't know I would hook it up that way, anyway.

BTW, I have been unable to find an explanation anywhere of the exact meaning of the State reports for nm-tool, the differences among unavailable, unmanaged and unconnected. Unconnected, I guess, means something previously connected but unplugged or something. The other two, however, occur in my nm-tool reports at various times without any seeming logic.

Any possibilities? Thanks for thinking about this...

Rojas 04-14-2012 03:54 PM

You mention that you have a router connected to one of your network interfaces. If DHCP is turned on in the router, that could be causing a malfunction.

eccampbell 04-15-2012 07:19 AM

How would I find out if DHCP is turned on in the router?

Rojas 04-15-2012 09:22 PM

You can adjust your router settings usually via a web-based interface. The IP address to access your router should be in the documentation or you can do a search for your router on the web.

Before you go too far with that though...what does your file '/etc/network/interfaces' say is the address of your network interfaces?

One of the interfaces should have an address of is the address LTSP uses for the network interface that is assigning ip addresses to your clients on the LTSP network.

eccampbell 04-20-2012 11:40 PM

I will check about the router situation next chance I have at the server, which will be Monday, thanks.

Meanwhile, I wonder if this line of troubleshooting has anything to do with my problem, which exists the same whether or not my gigabit LTSP router is connected to the computer. Now, I can set up LTSP with the router connected only to the computer but not to the internet cable, and as I remember (will check) is the address. But whenever I do that -- no matter which of the two network connectors I use for which (either eth0 or eth1, one on the mainboard and one on a PCI card) the other connection to the internet is shut off. But I can be connected to the internet on either network connector, so long as the other is not being used for LTSP. Again, this occurs whether or not the LTSP router is connected to the computer.

All times are GMT -5. The time now is 09:52 PM.