-   Linux - Server (
-   -   Editing partitions through SSH then mounting. (

mitchell7man 12-05-2009 12:56 AM

Editing partitions through SSH then mounting.
I have a partition on my server that is not mounting correctly, i am using cfdiskt to write the partition and then editing my fstab and mount -a. I have not been successfull yet, what is the best way to go about this process? Maybe something step by step so I don't miss anything. Is it that cfdisk just isn't formatting the partition really or what? I've tried this over and over.



root@kate:~# mount -a
mount: wrong fs type, bad option, bad superblock on /dev/sda3,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

# /etc/fstab: static file system information.
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda1 during installation
UUID=aa763522-2bd9-480d-9cef-7b6f9e3adc11 / ext4 errors=remount-ro 0 1

/dev/sda5 none swap sw 0 0
/dev/scd1 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd0 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
/dev/sda3 /media/media1 ext3 defaults 1 1
/media/media1 is chmoded to 777

mesiol 12-05-2009 02:50 AM


is there a filesystem on your partition? As the error message states the superblock of the filesystem cannot be found.

mitchell7man 12-05-2009 03:04 AM

i ran a command that it recommended and it is tellimg me that it cant find the ext3 file system on sda3. Is there a better way to partition via command prompt?

michaelk 12-05-2009 04:56 AM

To elaborate on mesiol's post cfdisk creates a partition but not a filesystem i.e it does not format). To create a filesystem use the mkfs command.

I assume this is a new partition and not an existing one that contains data.

mitchell7man 12-05-2009 05:19 AM

oh, okay. Thanks for helping out the noob.


All times are GMT -5. The time now is 11:29 PM.