-   Linux - Server (
-   -   dovecot unexpectedly terminating connections (

twisteguy22 07-18-2010 08:19 PM

dovecot unexpectedly terminating connections

I am running webmin on ubuntu server 10.04lts
I have dovecot installed.
when I try to check for mail the server unexpectedly terminates the connection. window live mail gives this error, and when i use telnet to try to login and get email it terminates the connection right after i send the "PASS thisismypassword" command.

any suggestion as to the nature of my problem or how to fix it?

jcalzare 07-18-2010 08:57 PM

What's in the dovecot log?

twisteguy22 07-18-2010 09:03 PM

where can i find the dovecot log? iv'e been looking. i have looked under /var/log but didn't find anything

jcalzare 07-18-2010 09:08 PM

I believe it uses syslogd for logging, so likely /var/log/maillog. Failing that, check in /etc/syslog.conf to see where mail is logged.

twisteguy22 07-18-2010 09:16 PM

the log show the errors:

POPOP3(myuser): mail_location not set and autodetection failed: Mail storage autodetection failed with home=/home/myuser
POPOP3(myuser): Fatal: namespace initialization failed.

what does it mean?

jcalzare 07-18-2010 09:23 PM

Read this: Your mail location is probably incorrect. You have to specify an inbox type (mbox, maildir, and so on before your location path.

twisteguy22 07-19-2010 07:20 PM

I can receive mail not in the client, but I can't send any using the client.
I can send mail from the command line of my server though.
when i check mail.log i see:
warning: SASL authentication failure: client didn't issue vaild NTLM response

thanks again for all the help.

jcalzare 07-19-2010 09:16 PM

It sounds like your mail client is trying to use an unexpected authentication type. Have you tried others in your email client? What SMTP server are you using?

twisteguy22 07-20-2010 06:08 PM

i haven't tried with other clients yet, will try with thunder bird, but it needs to work with live mail for other people of course.

I am using postfix, and webmin to do most of the config.

All times are GMT -5. The time now is 02:08 AM.