-   Linux - Server (
-   -   Domain not bound (

monojeffrey 01-14-2013 07:10 PM

Domain not bound
1 Attachment(s)
Attachment 11618

am new to linux, while booting this process continues , couldn't complete the booting process , guide me to stop this process, also help me find the file where all the services has been mentioned , so we can enable or disable the services we need during the system start up

thanks for the help

chrism01 01-14-2013 07:36 PM

It depends on which distro you have; do you know the name/version?
IF you can get to the cmd line you can use

cat /etc/*release*

uname -a

Otherwise, check your Install media or watch the boot process carefully from the top; it should tell you there.
That screen dump looks like RHEL/Centos, but it could be something else.

The YPBIND issue is because its looking for a remote NIS based authentication server eg

Many distros use the chkconfig cmd to set the services to start at boot time.

HTH :)

netnix99 01-14-2013 07:43 PM


The service that is holding you up is ypbind, located at /sbin/ypbind. It is the client service for NIS. It can be started different ways depending on your configuration. You will probably have to use a rescue CD, and boot from it, make the necessary changes, and then reboot again. ypbind can be started from either the /etc/rc.local file and/or chkconfig. You will also want to comment out any information in the /etc/yp.config file such as domainname and servername. This is assuming you don't want to use NIS. If you intend to use NIS, you will want to correct any inforamtion that may be incorrect in these files, such as servername or domain name.

monojeffrey 01-20-2013 08:57 PM

Rescue mode
1 Attachment(s)
I entered into rescue mode , as you said c couldn't find the files (configs) to edit and i have taken the info about the distro

is it possible to edit the configs and make changes to the files (through which we can enable specific services for each runlevels
example ,In init 2 certain services we can start additionally
and in init 3 , we should be able to stop some services

thanks for the reply

netnix99 01-21-2013 11:47 AM

When you entered rescue mode (assuming this is a Red Hat based distro from the looks of the images) did you

chroot /mnt/sysimage
before you took the screen shots? This takes the actual installed system and mounts it at /mnt/sysimage for editing. In rescue mode, when it dumps you to the shell, I am pretty sure you will be missing the specified system files because the resuce mode will not perform those options (such as: NIS functions, etc)

monojeffrey 01-22-2013 06:26 AM

Solution to stop
What is the solution to stop Yp (NIS) and to restore the server to normal running state
am using Red hat 5

netnix99 01-22-2013 08:21 AM

Once you perform the chroot, you have to find out what is starting the ypbind service and stop it. It could be many things or a combination of several things. Check the /etc/rc.local to see if ypbind is starting there (there will be a line with /sbin/ypbind). You can also edit the /etc/yp.conf file and remove the statement that defines the domainname and the NIS server. You should also be able to access chkconfig from here.


chkconfig --list
if ypbind is on, you should see:

  ypbind                0:off        1:off        2:on        3:on        4:on        5:on        6:off


chkconfig ypbind off
should provide:

  ypbind                0:off        1:off        2:off        3:off        4:off        5:off        6:off

monojeffrey 01-23-2013 08:33 PM

Stopped the yp bound service
Successfully stopped the yp bound service

also how to do this
adding reputation(after this i would close the thread)
help me to add your repution
thanks for the timely help

chrism01 01-24-2013 01:30 AM

In the left hand side box, there's a 'Rep' button; click that.
On the bottom right of the msg box, there's also a 'Did you find this post helpful? Yes' button; you can click that too if you want. :)

monojeffrey 01-24-2013 03:45 AM

to chrism01
thank u ..

netnix99 01-24-2013 07:28 AM

Glad to help!!

All times are GMT -5. The time now is 12:49 PM.