LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 05-20-2008, 02:03 PM   #1
lumix
Member
 
Registered: Mar 2007
Distribution: Hardy (Gnome on Ubuntu 8.04) on Compaq N600c laptop
Posts: 323

Rep: Reputation: 30
Does a new NIC need to be manually configured in Ubuntu server?


Running Ubuntu server 8.04:

I had to replace the network card but the server doesn't automatically recognize it. Is this a design feature? For ha-ha's, I started the Ubuntu CD in the same setup and the setup did recognize the new NIC. So how do I go about installing the driver manually? The card is old and the driver is no longer available, but clearly the Ubuntu CD has something that works, since I'm pinging it now, only a few steps into an installation process. Again, I only started the installation to test out the functionality of the card (it works, I now know), but I DON'T want to actually reinstall Ubuntu server.

Any thoughts?
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 05-20-2008, 02:25 PM   #2
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 131Reputation: 131
I guess you should try to find out which module is required for that NIC and then insert it manually (sudo modprobe). NIC driver issues appear to be widespread with 2.6.24 kernels, it's not just Ubuntu. I have recently had to patch and recompile one of those drivers on Fedora 8 although it worked perfectly fine until I did a kernel upgrade.
 
Old 05-20-2008, 05:01 PM   #3
Russianspi
LQ Newbie
 
Registered: May 2007
Posts: 19

Rep: Reputation: 2
May be a different problem...

Hmmm. Are you sure that it is actually a driver issue? I'd be willing to bet that if you ran
Quote:
ifconfig -a
your new NIC shows up, albeit without an ip address. The trouble may well be, that on Ubuntu server, new NIC's, although automatically recognized, don't activate by default. Assuming that ifconfig shows your card, look at
Code:
/etc/network/interfaces
and see if your new card is there. If not, add something like:
Code:
auto eth1
iface eth1 inet dhcp
to use dhcp, or something like
Code:
auto eth1
iface eth1 inet static
address 192.168.1.50
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
to use a static IP address.

When you have finished, run
Code:
/etc/init.d/networking restart
or just restart the server. That might well fix your problem. Good luck!
 
2 members found this post helpful.
Old 11-27-2010, 03:24 PM   #4
jlpeifer
LQ Newbie
 
Registered: Sep 2010
Posts: 3

Rep: Reputation: 0
Very helpful Russianspi!!! Thanks.
 
Old 03-09-2011, 06:52 PM   #5
fro1269
LQ Newbie
 
Registered: Oct 2010
Distribution: Centos 5.5, Ubuntu 10.04 , Fedora 14
Posts: 6

Rep: Reputation: 0
I have encountered this issue whenever I clone a VDI file in virtualbox and then add the vdi file to a vm on a different machine. It seems everytime I clone the VDI file, I need to go into /etc/network/interfaces and change the increment on eth* up one. Is there a way that I can reset this so I can go back to using eth0?

Last edited by fro1269; 03-09-2011 at 06:53 PM.
 
Old 07-04-2011, 04:42 AM   #6
chrismyers
LQ Newbie
 
Registered: Dec 2005
Posts: 1

Rep: Reputation: 0
This is a common problem also when a Vmware machine is moved to another server.

It is beacause the new card has a different MAC address.

Unlike Ubuntu Desktop, the server version is desgned NOT to make an assumption of how the card is configured - just in case it gets it wrong & places vulnerable data outside a firewall on the Internet.

You can enable the card easliy by deleting a file:

sudo rm /etc/udev/rules.d/70-persistent-net.rules

Then reboot.

This file is recreated with the new card MAC address upon reboot.

Then check your settings.

Cheers.

Last edited by chrismyers; 07-04-2011 at 04:48 AM.
 
Old 07-24-2011, 11:35 AM   #7
cycocool
LQ Newbie
 
Registered: Jul 2009
Location: Ireland
Distribution: Ubuntu server 14
Posts: 18

Rep: Reputation: 0
Quote:
Originally Posted by chrismyers View Post
This is a common problem also when a Vmware machine is moved to another server.

It is beacause the new card has a different MAC address.

Unlike Ubuntu Desktop, the server version is desgned NOT to make an assumption of how the card is configured - just in case it gets it wrong & places vulnerable data outside a firewall on the Internet.

You can enable the card easliy by deleting a file:

sudo rm /etc/udev/rules.d/70-persistent-net.rules

Then reboot.

This file is recreated with the new card MAC address upon reboot.

Then check your settings.

Cheers.
have a similar issue and when i did the above, the lan port was enabled but the eth0 still isnt detected when i check with 'ifconfig'. any ideas?
 
Old 11-14-2011, 01:16 PM   #8
Closetheloop
LQ Newbie
 
Registered: Nov 2011
Posts: 1

Rep: Reputation: Disabled
Delete /etc/udev/rules.d/70-persistent-net.rules

@Chris Myers

Thanks a bunch for your advice Chris. Dell changed the motherboard in my Ubuntu 10.04 server today and that meant they installed two new NICS as well. The new setup did not get recognised on the network but luckily your technique:

1) deleting a file: sudo rm /etc/udev/rules.d/70-persistent-net.rules
2) reboot

fixed a big problem for me

Thanks
 
Old 12-19-2011, 02:30 PM   #9
rdingram
LQ Newbie
 
Registered: Dec 2011
Posts: 1

Rep: Reputation: Disabled
Just wanted to thank chrismyers for that tip. I had to replace a NIC on a server here in the office that runs 10.04. Deleted the rules file, shutdown, pull old nic, insert new nic, power up, everything works like nothing ever changed. Whole process took less than 5 minutes.

Gracias my friend.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NIC not configured properly mr-flibble Linux - Networking 4 03-28-2007 12:19 AM
Install Samsung printer manually in Ubuntu Server smells_of_elderberries Linux - Newbie 1 12-07-2006 07:07 PM
DWL-650+ WLAN NIC, driver ok, but can't be configured baosheng Linux - Hardware 1 07-29-2006 04:20 PM
Finding out if your NIC is configured properly rwescoat Linux - Networking 1 10-16-2004 03:38 PM
NIC won't stay configured Mahoot Linux - Hardware 5 09-09-2003 11:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 12:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration