LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   Disable xserver (grahics) on server (https://www.linuxquestions.org/questions/linux-server-73/disable-xserver-grahics-on-server-650132/)

halvorls 06-18-2008 01:37 PM

Disable xserver (grahics) on server
 
Hi!

How can i disable th x server (graphics)?

Halvor

marwansherin 06-18-2008 02:16 PM

try sudo telinit - 1 at the terminal

for more details take a look at man telinit
just open a terminal and type man telinit

it works fine on ubuntu

yawe_frek 06-19-2008 09:04 AM

what flavour of linux are u on

mtimbro 06-19-2008 10:12 AM

Hi,

I'll assume that what you're trying to do is boot in non-graphical mode permanently.

I'll also assume that you're on a RH / Fedora / Centos / Suse / OpenSuse platform. Other platforms do it differently I believe.

Edit the /etc/inittab file and alter the following line:

id:3:initdefault:

The number you probably have instead of 3 is 5, which is graphical mode.

Hope this helps,

halvorls 06-20-2008 02:18 AM

Quote:

Originally Posted by mtimbro (Post 3189402)
Hi,

I'll assume that what you're trying to do is boot in non-graphical mode permanently.

I'll also assume that you're on a RH / Fedora / Centos / Suse / OpenSuse platform. Other platforms do it differently I believe.

Edit the /etc/inittab file and alter the following line:

id:3:initdefault:

The number you probably have instead of 3 is 5, which is graphical mode.

Hope this helps,

Hi!

I use debain linux, how can i disable xserver at boot?

nx5000 06-20-2008 02:44 AM

Quote:

Originally Posted by halvorls (Post 3190066)
Hi!

I use debain linux, how can i disable xserver at boot?

Depends which program is starting it. Do you use kdm/gdm? kde or gnome or something else?

update-rc.d -f gdm remove
update-rc.d -f kdm remove


All times are GMT -5. The time now is 04:41 PM.