LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Server (http://www.linuxquestions.org/questions/forumdisplay.php?f=73)
-   -   Disable all bind zones (http://www.linuxquestions.org/questions/showthread.php?t=4175456037)

bcbirk 03-29-2013 12:09 PM

Disable all bind zones
 
We have an internal server that was partially set up by someone who knew way too much for his own good. He set it up do cache dns internally and be the soa for all the zones internally. It's become a real problem when updating dns for domains, and it's cached internally. Restarting named doesnt' flush that internal cache for some reason. I'd like to set up bind so it is simply caching, and remove all the zone files, if that's possible. If not , then I'd like to just disable bind completely and go back to how it was before it was set up. How do I go about doing that. If I simply shut off bind, then nothing will resolve internally. We can't access the internet. What config files do I need to modify to fix this.

Thanks.

gilead 03-29-2013 03:41 PM

If you've never configured BIND before, the howto here is useful for getting a basic understanding. Once you have that, you can decide which will be better in your situation. Disabling that instance of BIND and using a different name server is easy enough - do you have another server you can point /etc/resolv.conf to?

bcbirk 03-29-2013 05:42 PM

Thanks gilead. That link helped out a lot. I am waiting till most folks leave for the day so I don't screw up the internal network, but I think I got it figured out. I simply removed most of the zones from the named.conf file and that should take care of it. From my understanding, whatever isn't specified in a zone, will resort to using one of the other dns servers listed in the resolv.conf. In this case, I am using our isp's dns servers. Once I restart I'll know if it worked :D Wish me luck.

gilead 03-31-2013 02:19 PM

Doesn't sound like you need luck - have fun :)

Ginola 04-01-2013 05:15 AM

Quote:

Originally Posted by bcbirk (Post 4921325)
From my understanding, whatever isn't specified in a zone, will resort to using one of the other dns servers listed in the resolv.conf.

I think it will first try a resolution from what forwarders have been configured in the options section of the named.conf.

Just to be sure, its the named server not updating, and nothing to do with nscd, right?

chrism01 04-02-2013 01:14 AM

Quote:

In this case, I am using our isp's dns servers.
That will only work if the required domains are publicly registered ie on the internet.
If they are internal to your company/LAN only, then you need an internal DNS server.


All times are GMT -5. The time now is 01:03 AM.