-   Linux - Server (
-   -   dhcp.conf problem: host fixed-address declarations ignored (

lslade 03-05-2007 02:47 PM

dhcp.conf problem: host fixed-address declarations ignored
I have several fixed-address declarations for hosts on my network. Most of them work. However at least two of them are being ignored.
The server is Debian sarge. One of the two problem clients is a Windows 2000 server and the other is a Fedora core 4 machine.

Here is one declaration that is OK for a Windows 2000 client and the second one which does not work is the Windows 2000 server. I have tried both lower and upper case for the characters in the mac addresses.

host support02 {
hardware ethernet 00:90:F5:28:1E:B0;

host Acadlicserver {
hardware ethernet 00:07:95:1c:7b:e1;

I have run a trace on the transaction from the client end. The client does a DHCP discover then the server sends a DHCP offer with the old IP address - the one the client had got dynamically before the host declaration was added. The client then sends a request for that address and the server sends a DHCP ACK.

I have already tried stopping the server, deleting the old leases from dhcp.leases, then starting the server again.

SOLVED : Old Debian install had /etc/dhcpd.conf and /etc/dhcp3/dhcpd.conf left over. Was editing the wrong one.
yeaarg. Should have used this procedure: Read /etc/init.d/dhcp3-server to make sure what the conf file was. OK, there's no hint here. Next use lsof to check what files dhcpd is using.

All times are GMT -5. The time now is 01:40 AM.