LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   Debian apache2 phpbb doesn't work, always displays "it works" (https://www.linuxquestions.org/questions/linux-server-73/debian-apache2-phpbb-doesnt-work-always-displays-it-works-628114/)

1veedo 03-14-2008 05:37 PM

Debian apache2 phpbb doesn't work, always displays "it works"
 
This is strange despite removing apache2-default, having an index.html page and a folder "forum" whenever I go to my server it says "It Works!"

My phpbb forum isn't working either, I'm not sure if that's related. I used to have a web server on ubuntu and phpbb working fine.

j-ray 03-15-2008 04:22 AM

so you type http://localhost/forum/index.html
and the response ist "It works" ?

1veedo 03-15-2008 01:55 PM

No actually I get a bunch of errors. The installer didn't work, when I clicked finish it just brought me to a white screen.

When I go to 127.0.0.1 it was saying "it works." I've rebooted sense then and now it's giving me a 404 "The requested URL /apache2-default/ was not found on this server." I don't see why it's trying to loat apache2-default when I have index.html and even still have a folder "forum" in /var/www.

j-ray 03-16-2008 05:46 PM

you can take a look at the apache2.conf file or maybe it is httpd.conf where most cofiguration is set. The variable where apache looks for documents is called
DocumentRoot="/path/somehwere"

if it set to /var/ww/apache-default or similar then apache now is in trouble to find that. It cannot serve any pages if this setting is not adjusted. Every page thh is to be displayed must reside inside of this directory...

after changing config you have to restart the server to put changes into effect...

1veedo 03-20-2008 09:11 PM

Think I found the problem. I didn't look at the config files but httpd.conf is empty. In fact there's no configurations there except mods for php and apache2.conf which is basic stuff, none of the server roots and standard apache configurations (like <directory> stuff).

brianhenson 03-21-2008 02:25 AM

To turn off the default it works page go to (assuming default installation) /etc/apache2/sites-available/ and edit the file called default you are looking for this string RedirectMatch ^/$ /apache2-default/ put a # in front of it and then restart apache with this command /etc/init.d/apache2 force-reload and then test out and try the installer again. If you do to the directory and just see the listing of the files php may be setup incorrectly. I would also try this create a new file called test.php and put this code into it
PHP Code:

<html>
<head>
<title> PHP Test Script </title>
</head>
<body>
<?php
phpinfo
( );
?>
</body>
</html>

This will show you a listing of your current php settings.

just my 2c

1veedo 03-22-2008 09:26 PM

Yeah that worked thanks. I used to know a lot about apache's config files but the past year or so every distro I've installed apache2 with had everything set up and working automatically (even php and mysql).


All times are GMT -5. The time now is 08:28 AM.