Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Server
User Name
Linux - Server This forum is for the discussion of Linux Software used in a server related context.


  Search this Thread
Old 07-28-2008, 03:43 AM   #16
LQ Guru
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,456

Rep: Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402

Try sending the same amt of data using a different tool for speed comparisons eg try scp and rsync (sans ssh option).
Those tests will tell you if its a Samba protocol issue.
Old 07-28-2008, 07:18 AM   #17
Registered: May 2001
Posts: 29,362
Blog Entries: 55

Rep: Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548
I'd vote for using something with less overhead instead, like netcat.
Old 12-31-2010, 09:40 AM   #18
LQ Newbie
Registered: Dec 2010
Posts: 1

Rep: Reputation: 0

Probably you are using ntfs in your target. Large file writing slow down is a known bug in ntfs-3g driver.

Try to split the target file. For instance:
sudo pv -ptreb -B 16384k /dev/sda | dd bs=16384k conv=notrunc,noerror | split -b 16384m - /media/disk/targetfile.img.
(don't forget to finish the target file name with a dot)

It will split the resulting file in parts of 16GB (pv command if for showing the progress, -B if using a 16MB buffer)

Last edited by swans; 12-31-2010 at 09:49 AM.
Old 06-13-2011, 07:14 AM   #19
LQ Newbie
Registered: Jun 2011
Posts: 1

Rep: Reputation: Disabled
I had a similar problem: dd slowed down after copying 20-40 GB into one file, and this seems to be because of the size of the output file.
My solution is the following: I split up the output of dd with split:
dd if=/dev/sdc2 bs=5120 oflag=dsync skip=15775829 | split --bytes=1G - /targetdirectory/x
I used oflag=dsync in case it helps - I didn't experience any difference.
I used skip=15775829, because I have already copied 15775829x5120 bytes to another file.
The hyphen before target directory indicates that split gets the input from standard input.
Note that split creates files with suffixes of 2 letters by default (e.g. xaa, xab, xba, ...), and this only allows 676 files. To use more letters, use the argument --suffix-length=N, where N is the desired number. See man split for more details.
To reproduce the copied data as one file for dd as an input you can use something like this:
cat /path/to/files/prefix* | dd of=/dev/sdc2 bs=5120 oflag=dsync
I hope I could help. Be careful using dd, it can easily overwrite your important data.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Xterm (any X terminal) starts fast, but initializes very slow Kevschef Linux - General 3 11-09-2006 12:36 PM
10Mb/s and 100Mb/s on same network plisken General 2 05-07-2003 10:28 AM
Onstream IDE 30GB Installation jeucken Linux - Hardware 2 08-01-2002 12:53 PM
Harddisk problems, seems to forget about the last 30Gb... Thymox General 7 05-21-2002 10:15 AM
30gb Linux Installation vcheah Linux - Software 2 12-06-2001 07:28 PM > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 07:27 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration