-   Linux - Server (
-   -   Cron Schedule Issue (

richinsc 03-01-2008 12:53 PM

Cron Schedule Issue
After editing my crontab to include my backup script a new error has started appearing that i have tried to correct but have so far been unsuccessful. I have for the past two days been receiving the following email every hour. Below is the msg.


/bin/sh: root: command not found
Here is my crontab. I have check to make sure that there are no extras spaces then is required.


# /etc/crontab: system-wide crontab
# Unlike any other crontab you don't have to run the `crontab'
# command to install the new version when you edit this file
# and files in /etc/cron.d. These files also have username fields,
# that none of the other crontabs do.


# m h dom mon dow user  command
17 *    * * *  root    cd / && run-parts --report /etc/cron.hourly
25 6    * * *  root    test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.daily )
47 6    * * 7  root    test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.weekly )
52 6    1 * *  root    test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.monthly )

# Backup of County data and system configuration
# m h dom mon dow user  command
00 21  * * *  root    /etc/cron.daily/backup.cron

I had to add the line for my backup script directly because cron wouldn't execute it even thought it was included in /etc/cron.daily directory. Any advice would be well appreciated.

Edit: Forgot to add that this error is only for the /etc/cron.hourly line.

bathory 03-01-2008 05:36 PM

IIRC you cannot have a dot "." in the command/script you want cron to run. So rename your script to just plain backup and see if it works.


billymayday 03-01-2008 05:57 PM

I cetrtainly call my scripts .sh, and I run these from cron with a dot in them OK.

Why not just put your backup in root's crontab with crontab -e, but omit the user, ie:


00 21  * * *  /etc/cron.daily/backup.cron
instead of


00 21  * * *  root    /etc/cron.daily/backup.cron

choogendyk 03-01-2008 06:32 PM

If you are getting this error every hour, what makes you think it is your daily cron?

where is "run-parts"? If sh can't find something, and it is happening every hour, it would seem you might want to look at that.

All times are GMT -5. The time now is 07:24 AM.